[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

can't install emacs21 and german keymap?

i have two problems with GNU/Hurd.

1. I have tried to install emacs21 with apt-get, but i get always this
error message:

emacs21: error while loading shared libraries: libXaw3d.so.6: cannot open shared object file: No such file or directory
emacs-install: /usr/lib/emacsen-common/packages/install/emacsen-common emacs21 failed at /usr/lib/emacsen-common/emacs-install line 28, <TSORT> line 1.
dpkg: error processing emacs21 (--configure):
 subprocess post-installation script returned error exit status 29
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

any ideas what's going wrong?

2. How do i install a german keymap?
On german GNU/Hurd sites i have found a link to a german keymap
(ftp://alpha.gnu.org/gnu/hurd/contrib/marcus/keymap.tar.gz), but this
link doesn't work.
So i have tried it the "debian-way", i have installed console-common and
console-data. But when i select the german keymap, console-data tells
me that i need console-tools or kbd.
Console-tools is replaced by console-common, which i have installed
and kbd-compat depends on console-tools (= 1:0.2.3.dbs-38) and

Can someone help me?

Thanks a lot && Best regards

Reply to: