[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: pam patch

--- Michal 'hramrach' Suchanek <hramrach_l@centrum.cz> wrote:
> I think this makes pam buildable under the Hurd. I do not know if I did 
> something stupid and I do not use the affected modules myself.
> Could anybody look at it or even test it?
> Thanks


  This program seems to be only for GNU/Linux, so you can expect it to only run

on GNU/Linux which should always have asprintf.  Using asprintf is usually the
right way to go, unless the upstream source needs to support solaris.  As Jeff 
said sometimes a patch like this is needed to get upstream to accept it.
in this case upstream does not need to use PATH_MAX.

  I hope that helps.

James Morrison
   University of Waterloo
   Computer Science - Digital Hardware
   2A co-op

Anyone referring to this as 'Open Source' shall be eaten by a GNU

Do you Yahoo!?
Faith Hill - Exclusive Performances, Videos & More

Reply to: