[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Login Shell on Serial port

rmgolbeck@uwaterloo.ca (Ryan M. Golbeck) writes:

> I'm trying to get gnumach to start a login shell on the serial port.
> I have uncommented the line in /etc/ttys that reads:
> com0   "/libexec/getty 9600"      dialup     on    secure
> On reboot, runsystem segfaulted with the following error:
> /libexec/runsystem: line 140:      90 Segmentation fault    ${RUNTTYS}
> I have tried changing dialup to vt100 with the same results.  From
> gnumach's startup messages, it appear as though my serial port at com0
> is detected fine and the link works fine because grub is properly
> putting itself onto the serial port during boot up.

I have tried commenting out the console line in /etc/ttys (this idea
is from a thread from about a year and a half back in this list), and
it doesn't segfault but neither does it sent anything out onto the
serial port.

Ryan Golbeck <rmgolbeck@uwaterloo.ca>
Computer Science
University Of Waterloo

GPG: 1024D/78916B84 
1B1B 2A87 3F00 A7FB 40F3  526D 36CF BA44 7891 6B84

Reply to: