[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: libc6?!!!

Vadim Chekan wrote:
> I can't install g++ on my Hurd based on D1 dist.
> apt-get install g++
>   g++: depends: libstdc++2.10-dev (>=1:2.95.2-10) but it not going to be
> installed
> apt-get install libstdc++2.10-dev
>   libstdc++2.10-dev : Depends: libc6-dev (>=2.1.95)
> apt-get install libc6-dev
> Note, selecting libc0.2-dev instead of libc-dev
> Sorry, libc0.2-dev is already the newest version
> What's going? How much libc there exist?

In GNU/Hurd the names are "libc0.2" and "libc0.2-dev". Therefore
libstdc++2.10-dev should be modified so that its hurd-i386 version
depends on "libc0.2-dev", not libc6-dev.

> Should I "force" libstdc++2.10-dev to be installed?

Yes, I think it would be safe to do so.

Reply to: