[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [Robert Bihlmeyer <robbe@orcus.priv.at>] Re: XEmacs 21.2 on the hurd

>>>>> "APA" == Adrian Aichner <adrian@xemacs.org> writes:

>>>>> "Karl" == Karl M Hegbloom <karlheg@bittersweet.inetarena.com> writes:
>>>>> "Martin" == Martin Buchholz <martin@xemacs.org> writes:

    APA> <lines deleted by Adrian>

 [ below I am referring to setting up a Hurd box with logins for porters ]

    Karl> Maybe I can arrange that; give me a few days.  I've a spare box and
    Karl> am actually really curious about Hurd anyway...  I'll attempt to
    Karl> install it and see if I can make it possible for you to `slogin' via
    Karl> BitterSweet to it.

    Karl> Hmmm... what should I name it?

    APA> Hmmh, how about hurdy-gurdy?

 Hey, good name; but Hurd doesn't support sound cards yet.  I settled
 on calling it "buttercup", after the jersey cow we had when I was a
 kid.  So "GNU buttercup 0.2 GNUmach-1.2/Hurd-0.2 i386-AT386 unknown"
 is sitting on "buttercup.intra" inside my apartment LAN.

 It was not difficult to install.  The way that worked best (three
 tries) was to use a Debian GNU/Linux 2.2r0 CD-ROM, and install that.
 I partitioned with one 128Mb swap, two 500Mb and one 1.2Gb ext2
 partitions.  The two 500Mb ones are for Hurd, created from Linux

 mke2fs -o hurd -O none -O sparse_super -L 'Debian GNU/Hurd' /dev/hda{2,3}

 ... It's important, I found, to use the "-O none -O sparse_super"
 magic, or else Woody mke2fs will use the "file_type" option, which
 Hurd does not support, giving massive "fsck" errors.

 I then mounted the first one under /gnu, and used the "cross-install"
 script to wget and install the packages.  I got "grub" set up, and
 booted to Hurd, then ran "native-install", rebooted, ran
 "native-install" the second time, created devices for the hard
 dirves, and set up the eth0 with an address inside my LAN.

 `apt-get' doesn't work under Hurd; it tries to, but first of all
 tries to get "binary-i386" until I edit the sources.list... fixed
 that, and then still; it did this before also; rather than a 404 it
 bombs out saying "Socket Expection" (sic).  What's worng with it, I

 I cannot get `ncftp' to work either.  Grrr.  It keeps saying "illegal
 port command"; I did "set passive on" too... normal `ftp' works after
 setting "passive", but it's not as easy to use.  I'm running a 2.4.0
 kernel on BitterSweet, with IP-Masq and the IPchains module.  There
 used to be an ftp_masq module that's not present anymore.  How can I
 get that functionality in 2.4.0?  I imagine IPtables does
 it... there's a module with "ftp" in the name.  I've not learned to
 configure IPtables yet.

 There is no compiler suite or anything yet.  I've got to dink around
 getting that installed, via ftp by hand, unless somebody knows the
 magic that makes "apt-get" not cause "Socket Expection"'s.

 I figured out how to make a proxy/tunnel from a port on
 bittersweet.inetarena.com through to the sshd/telnetd on
 "buttercup.intra".  It worked (tested for one simultaneous remote
 login from master.debian.org) when "buttercup" was running Linux;
 I've not tried it to Hurd yet; I imagine it will work fine once I can
 telnet in more than one login at a time.  Perhaps I'll have to hack
 up a way to open several ports via inetd?  I don't know if the ssh
 tunnel will accept more than one connection to the outer port and
 forward them all yet.  Does anyone have experience with this sort of
 thing?  Anything I can read?  "buttercup" is behind my IP-Masq Linux
 gateway and I don't have a spare LAN Hub or IP to put it on the other
 side of it.

 When I get this working better, I'll email again with the port number
 to ssh to, etc.  Please send an SSH public key if you want a login.
 (Martin B., I have your key still; it will be the first besides mine
 to be set up.)

We should not penalize the conscientious to coddle those who run brain-dead software.
I am karlheg, of deB.ORG.  You will be freed.  Resistance is useful.
mailto:karlheg@debian.org (Karl M. Hegbloom)

Reply to: