[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: sysvinit

On Sat, Oct 07, 2000 at 09:11:32PM -0700, jc wrote:
> apt-get output:
>  bsdutils: Depends: sysvinit (>= 2.59-2) but it is not
> installable
> Is there anything to be done about this?

Learn to use "dpkg -i --force-conflicts <pkgfile>" when needed.  Without
versioned Provides, you'll need to use it on a few packages.  Typically,
for packages that version depend on things provided by the hurd package.

Ummm.  Looking at the Packages file a bit....  I don't recall a problem
with bsdutils (but I'm using dselect/apt instead of apt-get), but I see
bsdutils has a versioned depends on shellutils which has a versioned
conflict with login which is provided by hurd.  I'm pointing this out
because, IIRC, I had to --force-conflicts to install shellutils after
which everything was fine.  I don't know if this conflict has been
resolved yet or you've run into a different one.  Strictly speaking, this
isn't a hurd problem but a limitation of the package management system.

A word of warning, it's possible to shoot your foot off by using
--force-conflicts carelessly.  Make sure you know what the conflict is
and why you're overriding it before proceeding.  One of the reasons
I use dselect is because I _like_ the conflict resolution screens -
I think they're helpful in sorting this kind of stuff out.  YMMV.

Good luck!

Steve Bowman  <sbowman@frostwork.net> (preferred)
Buckeye, AZ   <sbowman@goodnet.com> <bowmanc@acm.org>

Powered by Debian GNU/Linux and GNU/Hurd <http://www.debian.org>

Reply to: