[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Grub problem



Hello,

This evening I have tried to install GNU/Hurd on a test box I managed to
assemble from spare hardware.

Primary Master is a 800Mb hard drive, with Debian 2.2 installed.
Primary Slave is a CDROM
Secondary Master is a 170Mb, to be used for Hurd.
There is no floppy.
I will install another small disk (150) for the Hurd later.

I have a weird problem trying to install Grub in that machine. Hurd has
worked for me in every other box, but no in this one, and I can't see why.

/dev/hda1 is Swap, /dev/hda2 is ext2 with Linux and /dev/hdc1 is ext2 with
Hurd.

Lilo is installed in /dev/hda, without problems. Trying to install grub
0.5.95 into the mbr, I get this:

grub> root (hd0,1)
 Filesystem type is ext2fs, partition type 0x83

grub> setup  (hd0)
 Running "embed /boot/grub/e2fs_stage1_5 (hd0)"

Error: Invalid device requested

If I try setup (hd0,1) it works, but at boot time I get MBR, not grub.
Anyone has a clue? I want to boot gnumach to see if I got my compile right
but I can't :|

Attached to this mail is my menu.lst and device.map.
If you need more info about the system or whatever, please say so.

Thanks,

Jordi

-- 
Jordi Mallach Pérez || jordi@pusa.informat.uv.es || Rediscovering Freedom,
   aka Oskuro in    || jordi@sindominio.net      || Using Debian GNU/Linux
 Reinos de Leyenda  || jordi@debian.org          || http://debian.org

http://sindominio.net  GnuPG public information:      pub  1024D/917A225E 
telnet pusa.uv.es 23   73ED 4244 FD43 5886 20AC  2644 2584 94BA 917A 225E
# Grub Menu File for Contamination
#

timeout 5
default 0
fallback 1

# For booting Linux
title  GNU/Linux
root (hd0,1)
kernel /vmlinuz root=/dev/hda2

# For booting the GNU Hurd
#title  GNU/Hurd
#root   (hd1,0)
#kernel /boot/gnumach.gz root=hd2s1
#module /boot/serverboot.gz

# For installing GRUB into the hard disk
title Install GRUB into the hard disk
root    (hd0,1)
setup   (hd0)
(hd0)	/dev/hda
(hd1)	/dev/hdc

Attachment: pgpR1RJrfTUx4.pgp
Description: PGP signature


Reply to: