[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Initial trouble with X

Marcus Brinkmann <Marcus.Brinkmann@ruhr-uni-bochum.de> writes:

> On Mon, Sep 25, 2000 at 07:09:50AM -0700, Frederico Muñoz wrote:
> > I tried to get the packages but there was huge dependencies problems
> > (notably shell-utils 'conflicts' with login, and also pre-depends on 'login'
> > or 'hurd'... that made me do several mistakes - the removal of basic
> > packages that rendered my system useless... and I did a fresh install, since
> > I knew more this time and could avoid several errors).
> Maybe apt gets something wrong here... I will have to check the
> dependencies.

Oh, just FYI it didn't report any of this conflicts when I did my new
install, apt update and upgrade, etc;: I prolly had something broken...
> The Hurd provides login, and this should be sufficient for shellutils.
> But latest shellutils might have a versioned dependency, and dpkg 1.6.999
> has probably some bug here.
> Reverting to dpkg 1.4.13 might be an option for those who have problems.
> Forcing the instzall of shellutils should be okay also.
> > Also, when I put the ftp.de.debian.org line in sources.list (unstable main)
> > it reports a huge amount of packages... that prolly belong to Linux
> > woody... but if I specify binary-hurd-i386 apt tries to open
> > ...debian/dists/unstable/main/binary-hurd-i386/binary-hurd-i386 ... Is that
> > amount of packages (that include gnome, kde, netscape, Linux kernel,
> > etc...) normal? If not how do I get it to work?
> Everything allright. Those packages are binary-all.
> It's not the linux kernel, but the linux kernel SOURCE. It'snot gnome,
> but some hardware independant gnome data files. It's not netscape,
> but a wrapper script etc.

Ok, I see, thanks.
> > The solution was to comment out ftp.de.debian.org
> That's absolutely unnecessary and not recommended.

It was just a temp solution to be able to see the X packages without
having to get the whole lists; I have it on now :)
> > (after upgrading
> > everything, the hurd to the correct new version) and make do with
> > alpha.gnu.org... then I saw all the new X packages and installed them (I
> > pretty much installed them all, except for Xservers, only installed mine).
> > 
> > I had the following problems:
> > 
> > Making the mouse translator (settrans /dev/mouse etc) it says /dev/mouse,
> > file not found; I tried to do a MAKEDEV mouse but it gave me an error
> Did you read my email?

Yes, many times.
> 3. Set up mouse translator
>    This is a bit special. For me, with a serial mouse, this works:
>    settrans /dev/mouse /hurd/mouse --device=com0 --protocol=microsoft
>    (from memory). Read this document to find out:
>    http://f77.nop.or.jp/doc/XFree86-

Yes, I did that - by the way, does the part refering to the settrans
/dev/com0 /hurd/term apply?

> > (MAKEDEV kbd worked); reading the Japanese page (Yasushi's one) I saw that
> > with a serial mouse '/dev/mouse not needed'... is the error to be expected?
> It does not say such a thing, and the error is expected.

Ehehehe, it does when you view it with lynx, the tables become
hrizontal lines and it says '/dev/mouse   not needed' - refering to
the hurd patch :)
> > If not, what must I recompile?
> Nothing, just follow the instructions.
> For a simple serial mouse, use the above. For ps/2, replace "microsoft" with
> "ps/2". For other special settings, see the japanese site.

I created /dev/mouse with touch, I did the settrans, the mouse does
move but I don't have any control over it...

> > Anyway, the real trouble came later: I set up my XF86Config file, did a
> > startx and receives an error message saying something like
> > 'xauth: libXmu.so.6 not found'
> Oh right, I forgot one step:
> export LD_LIBRARY_PATH=/X11R6/lib
> startx
> The LD_LIBRARY_PATH setting will fix this.

Yes, it did, thank you once again.

> > Oh, and I sometimes get a 'default pager error: dumping blablabla', that
> > keeps appearing in my screen (like a $yes) and I have to reboot the system,
> > sometimes with the reset button)
> Do you have swap? You ran out of memory.

Yes, I have swap but I hand't turned it on at the time because it was
a fresh install and /etc/fstab wasn't updated.

> > I'm sorry if there is info that I don't give, I was just hopping that either
> > someone had the same problem and had a solution or if someone ever heard of
> > this problems.
> The shellutils problem I will investigate. All other stuff is easily
> fixable. I hope you have more luck this time!

I sure did, X runs, without mouse but it runs! I will prolly try to
compile something in it as soon as I become familiar with the process.
Thanks for your work on this and numerous other packages.

Frederico S. Muñoz

Reply to: