[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Latest Tarball Problems

Oh, of course.  I forgot to execute native-install.  I completely reinstalled my
hurd partition from the Mar 1 tarball and executed native-install.  That seemed to
fix the problem.  However, I did notice a few things:

1.  Despite installing the GCC package, I couldn't actually compile anything until
I copied over a handful of /lib/*.o files from the old 72Mb tarball.

2.  I can't get networking to work.  Previously, I used the command

settrans /servers/socket/inet /hurd/pfinet --interface=eth0 --address=

to configure the machine's IP address.  This worked great in previous versions,
but in this latest release, nothing ever happens.  I don't see the /hurd/pfinet
after a "ps -ax" like I used to.  Also, I noticed something peculiar about the
/servers/socket directory.  There are four entries:  1, 2, inet, and local.  In
previous versions, doing a "ls -l" on this directory would result in something

2: operation not supported
inet: operation not supported
crwxr-xr-x     ...        1
crwxr-xr-x     ...        local

Note the character to the left of the RWX bits is a "c".  I assume this denotes a
character device.  After installing the latest version, I get three files that
show, and it looks more like this:

2:  operation not supported
crwxr-xr-x     ...        1
lrwxr-xr-x      ...        inet
lrwxr-xr-x      ...        local

This time, the inet and local entries show up as symbolic links.

Any ideas?

Kevin Musick

Marcus Brinkmann wrote:

> On Sat, Mar 25, 2000 at 11:36:09AM -0700, Kevin Musick wrote:
> > I've been using the Hurd successfully for some time, but I recently
> > installed the latest tarball (March 3 I believe) and am now having
> > problems using GCC.  It gives me the following error:
> >
> > ld: /lib/libc.so.0.2: _del_sysdep_start: invalid version 6 (max 5)
> > /lib/libc.so.0.2: could not read symbols: Bad value
> >
> > If I check my GCC version using "gcc -v" I get:
> >
> > Reading specs from /lib/gcc-lib/i486-gnu/
> > gcc version
> Well, seems the gcc272 package is broken. Don't worry, you shouldn't use it
> anyway.
> > I downloaded the gcc_2.91.66-1.2.deb package, but when I attempt to
> > install it using "dpkg -i" I get the following:
> >
> > Preparing to replace gcc 2.91.66-1.2
> >    gcc depends on libc0.2 (>= 2.0); however,
> >         libc.0.2 is not configured
> So why is libc0.2 not configured? Your installation is not 100% ok.
> I don't believe native-install (did you run it?) run without errors.
> > I get similar messages that cpp (>=2.91.66) is not configured, and
> > binutils (>= 2.9.1) is not configured.  It seems by these messages that
> > dpkg thinks the version I'm running is already the newer version.  I
> > next tried to install libc0.2_2.1.2-10.deb, but then I get:
> >
> > Preparing to replace libc0.2 2.1.2-10
> > Version of dpkg with working epoch support not yet configured.
> >    Please use dpkg --configure dpkg
> This is definitely wrong. The dpkg in the archive (and tar file) is a bit
> oldish but has epoch support. (Lack of epoch support predates even the hurd
> :)
> > Hmmm.  Am I getting these problems because I use the tarball install
> > method?  I've NEVER been able to get the debian package manager to
> > install anything.
> Did you run native-install? What output did it produce? It will configure
> the packages, only THEN the installation is complete.
> Thanks,
> Marcus
> --
> `Rhubarb is no Egyptian god.' Debian http://www.debian.org Check Key server
> Marcus Brinkmann              GNU    http://www.gnu.org    for public PGP Key
> Marcus.Brinkmann@ruhr-uni-bochum.de,     marcus@gnu.org    PGP Key ID 36E7CD09
> http://homepage.ruhr-uni-bochum.de/Marcus.Brinkmann/       brinkmd@debian.org

Reply to: