[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: GRUB 0.5.92 problem

On Sat, 7 Aug 1999, OKUJI Yoshinori wrote:

>   Perhaps RedHat has an old and buggy version of binutils. You can
> examine what version you use by "ld -v". See the requirement in the
> file README.

Ah. I thought my old version ( was fine, as no compiler errors
occured. It works nicely now that I have the new . However, I
am having trouble with getting grub to use passwords. I type in the
correct password, but it gives me a "Failed!" message. I tried running the
simulator under gdb, and the password variable is correctly set to
"<my password> (hd0,1)/boot/grub/menup.lst"

Also, I am having trouble booting up other bootloaders off floppies from
grub (with chainloader command). I tried to boot up a grub boot disk from
the grub on my harddrive, and it gave me a Hard Disk Error when I typed in
boot. I tried to boot up my redhat install disk, and that didn't word
either. When I tried to boot up my master bootloader (lilo), from grub, it
worked fine, and lilo is able to boot these 2 floppies with no problems. 

Reply to: