[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

impressions from a hurd newbie

Marcus Brinkmann wrote:

> What's up?

sorry about that mail ... i was trying to figure out how to subscribe to
the hurd lists (debian, help and bug) so i tried to wake up the
majordomo (or whatever) help agent. anyways, i'm on the lists now :-)

here goes something of more interest, i hope. i installed the hurd a few
days ago and am a complete newcomer to it. so here are a few impressions
i've got from it so far:

* i installed from a freebsd 3.2 stable from the gnu-*.tgz. it was quite
easy, but for the fact that i didn't find the easy guide soon enough, so
i kept wondering what the device naming was that i needed to give to
serverboot. the link to the easy guide is broken in many pages, because
the original site doesn't seem to respond. do you think you could fix it
in your debian page? it used to be mirrored on the gnu pages here, where
it's still kept:

* i've got 64 megs of ram, and since i don't use X (don't know how to
get it to work anyways) i thought that would be enough, so i didn't
bother with swap space, and i kept running into "(default pager):
dropping data_request because of previous paging errors". could you add
something explaining that this message means "ADD SOME MEMORY, YOU
STUPID HUMAN" to some faq or doc ?

* once i'd figured out what the cause was, i tried to make the hurd swap
on my freebsd swap partition. it worked, but rebooting into freebsd
showed me that the hurd had swaped ON my disklabel, so i spent the rest
of my night trying to recall what the sizes of the partitions were.
quite fun indeed :-). i've got 2 questions about this point: does anyone
have a clue to what might have happened? and since i don't want to
rewrite my disklabel on every reboot, and considering the fact that i
don't have any partitions left, is there a way to make hurd swap to a
file? (i don't fully understand translators, so there might be an easy
way to achieve this that i missed)

* sometimes (say, when i try ftpfs or ls -l into /dev) i get an error
that beats me: something like a "Gratuitous error" or something. i don't
have the exact message in mind, i'll try to grab it if there's interest.
what troubles me is that i can't find the word "Gratuitous" that was
printf'ed or something in any file inside gnumach-1.1.92-5/ or
hurd-19990616/, so i wonder which entity is returning that to me. is it
ls or cd, or something else ? i'm a freebsder, not used to the debian
way yet, so i don't know where to fetch the sources for these programs.
any pointers ?

* similarly, i once had the message "rm: cannot unlink `somefile`:
Computer bought the farm". actually quite funny, but i didn't get the
meaning yet. i suspect it's rm who's sending that back to me, but since
i don't know where to fetch the rm sources ...

* i sometimes get something like an error (sorry for the vagueness)
about not having fd/4 or the such. i recall having seen this on some
doc, but can't recall where. could you please point me to the right
place to look ?

* the behaviour of unsu is quite odd, try this: su root, then unsu, and
unsu again. then look at what user you are. is that a normal hurd
behaviour? i thought i'd report that because under normal unix systems,
such a behaviour would sound quite strange (or bogus ?).

* one last thing i wanted to report is that the netcat package seems to
build and work right, following the dpkg-source -x thing.dsc and
dpkg-buildpackage -B procedure i saw in one of the lists archive. as i
said, i'm not used to the debian way, so i might have missed some
errors, don't take my word for the thing being right :-)

well, that's all for now, sorry for the long post, and thanks for your

have fun,

Reply to: