[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Tale of woes: hard copy


Today I tried to install the Hurd for for the nth time in 2 months. As
usual, I met with no success, but I have carefully jotted down all the
details and messages I got. I ran the cross-install script, and after
shuffling different versions of the .debs and removing locales from the
oplist, the script ran to completion, and advised me to reboot and run the
script native-install. I did, and here is what I had in store for me: each
input and output line is preceeded by a %%%

%%% command> root=(hd1,0)
%%% Filesystem type is ext2fs

%%% command> kernel=/boot/gnumach root=/dev/hd1s1 -s
%%%  Loading: [format=Multiboot-elf, <0x100000:0x173067:0x0>,
                <0x274080:0x1d5ac:0x28e247, entry=0x100000]

%%% command> module=/boot/serverboot

%%% command> boot
%%% GNUMach 1.1.92
%%% AT386 boot: physical memory from 0x0 to 0x4000000
%%% pcibios_init: BIOS32 Service Directory structure at 0x000facf0
%%% pcibios_init: BIOS32 Service Directory entry at 0xfb170
%%% pcibios_init: PCI BIOS revision 2.10 etry at 0xfb1a0

%%% Probing PCI hardware
%%% hd0: ST32132A, 2015MB w/120kb Cache, CHS=1023/64/63
%%% hd1: CREATIVE CD1220E, ATAPI CDROM drive
%%% hd2: ST34321A, 4103MB w/128kb Cache, CHS=8894/15/63
%%% ide0 at 0x1f0-0x1f7, 0x3f6 on irq 14
%%% ide1 at 0x170-0x177, 0x376 on irq 15
%%% Floppy drive(s): fd0 is 1.44M
%%% FDC 0 is a post-1991 82077
%%% Failed initialization of WD-7000 SCSI card !
%%% EATA0: address 0x1f0 in use, skipping probe
%%% EATA0: address 0x170 in use, skipping probe
%%% ppa: Version 1.42
%%% ppa: Probing port 03bc
%%% ppa: Probing port 0378
%%% ppa:    SPP port present
%%% ppa:    EPP 1.7
%%% ppa: Probing port 0278
%%% scsi: 0 hosts
%%% scsi: detected total
%%% 3c59x.c: v0.99H 11/17/98 Donald Becker
%%% Partition check
%%%     hd0: hd0s1 hd0s2 hd0s4 < hd0s5 >
%%%     hd2: [PTBL] [523/255/63] hd2s1 hd2s4 < h2ds5 hd2s6 hd2s7 hd2s8 >
%%% com0: at atbus0, port = 2f8, spl = 6, pic = 4 (DOS COM1)
%%% com1: at atbus1, port = 2f8, spl = 6, pic = 3 (DOS COM2)
%%% Can't open server boot script /dev/hd1s1/boot/servers.boot: 2502
%%% Server boot script ? [/dev/hd1s1/boot/servers.boot]
%%% hd24: bad access: block = 28, count = 2
%%% end_request: I/O error, dev 16:04, sector 28
%%% (serverboot): Running without any paging
%%% Hurd server bootstrap: ext2fs.static[hd2s1] exec init proc auth
%%% Single-user environment: /hurd/init: /dev/console: No such file or
%%% /hurd/init: Using temporary console /tmp/console
%%% /hurd/init: Cannot execute /bin/sh: No such file of directory
%%% init: rebooting Mach (flags 0) ...

    ... and the machine reboots. This was all before running the
native-install script; unfortunately that stage just didn't arise.

Main question: Does any immortal have any clue to what is happening ?

I have some questions ..
1:  Is it necessary for the second IDE HDD to be a a Primary Slave ?
2:  GRUB, Hurd and Mach all use different partition naming styles; could
we have them use the same naming style, like the Linux style, which
almost all of us are used to ?)

(NOTE: Machine Geniune Intel Pentium 166Mhz, 64MB 100 Mhz SDRAM, Award
BIOS-11/11/1997, 2 IDE HDD's, both Seagate, 2.1GB is Primary Master, 4.3
GB is Secondary Master, CREATIVE ATAPI CDROM is Primary Slave, Standalone
with no network card, HP DJ670 printer attached to LPT1, mouse on COM2
IRQ3, modem on COM1 IRQ4, original Intel Socket 7 motherboard for P54C

Thanks in advance ...

Ashutosh Rajekar
I'm sorry my GMT time is really wild, but my sysadmin doesn't cooperate.

Reply to: