[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installation problems with GRUB

> >   Next, I tried obtaining a newer version of GRUB.  From
> > ftp.uruk.org/public/grub, I obtained grub-0.5.tar.gz,
> > dated August 20, 1998.  I created a GRUB boot floppy according to
> > the instructions included with that archive:
> >
> >   dd if=bin/stage1 of=/dev/fd0 bs=512 count=1
> >   dd if=bin/stage2 of=/dev/fd0 bs=512 seek=1
> >
> >   Unfortunately, using this GRUB boot floppy gave me the same
> > result.
> >
> That seems like a fairly old GRUB.  The debian ftp archive should
> contain a more recent version.  There might be some sort of issue
> if you are using new hardware.  If you install the hurd debian package
> on your slink system, or even do a:
> `dpkg -x grub*.deb /foo` you can get a known working copy of the stage1,
> stage2, etc., binaries on your system (this command will extract it
> to a "foo" directory without actually installing it on your system.)
> The two-part dd commands you listed above should work fine.
> Please try again using the debian package as instructed above, then
> let us know how it goes.
> -Brent

  Well, I tried it again last night, and I had the same problem.  I used
the grub .deb file from the sid/main/binary-hurd-i386 directory, which
is version 0.5.90.

  I was looking around today, and I discovered there's a newer version out,
0.5.91, which has LBA support and support for AMI/AWARD bios extensions.
I'm getting way over my head here, but those sound familiar -- I'm pretty
sure I've got an AMI bios, and my drives definitely do the LBA thang.

  In case it helps, when I boot Linux, in the kern.log file (and on the
console) I get the lines:

Partition check:
  hda: [EZD] [remap 0->1] [1584/255/63] hda1 hda2 <hda5 hda6 hda7 hda8>
  hdb: [EZD] [remap 0->1] [786/64/63] hdb1 hdb2

which leads me to believe there's something odd about my disk configuration.
Also, when I boot Windows 98, it uses EZ-BIOS so that I can use more than
8 GB of my big drive.  This was installed from the software I installed
when I added the drive.  I am trying to use the small drive for Hurd though,
which didn't require EZ-BIOS before I added the big one.

  I'll try using 0.5.91, and see if I get anywhere.  Failing that, I'll
grab the latest source from the CVS repository, try compiling that, and
see what happens.

  I'll let the list know how it goes...

Shane McDonald

Reply to: