[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

my experiences

ok, as requested in the faq or one of the files,  here are
my comments on installing the debian hurd dist.

I followed along with the "easy guide" for installing hurd from
a linux box.  I grabbed the files listed as well as the scripts
by marcus.  I booted into my linux system, and went at it.  [Note:
my linux system is a redhat dist (redhat-6.0 to be exact), which
is a source of some of my problems later down the road.]

    first complaint: the files listed in the guide are not complete.
      The up to date list is in the cross-install script itself,
      a point which is never mentioned..  This should probably be
      mentioned somewhere

I stumbled onto the cross-install instructions and started reading
through those, and grabbed the rest of the files I needed.  I
also noted a problem:

    second complaint: the cross-install can find files in the local
      directory or in a subdir (base, admin, text, etc).  *BUT*
      it uses wildcards to find files, so if the files are not
      stored in subdiretories, it is possible for the wildcard to
      pick up on the wrong file during the install process.  For
      example perl* will match perl_5* and perl_base*. 

So, I moved all the files to subdirs to make sure everything goes
smoothly.  I started to run the scripts and noticed a problem:

    third complaint: Some files need renaming.  In some cases the
       script tries to install stuff like "libc0.2" when the files
       are named libc0_2*.  I renamed files, it probably would have
       been easier if I just edited the script.

So files are all renamed, now I'm in business this time.  Ok, so
I start running it, and notice that I don't have the debian package
programs that I need.  Now here's a really big complaint, but its
aimed more at debian than the debian hurd project in particular.
I grabbed the debian sources and the debian premade bins.  First
I tried making the sources.  Guess what?  dpkg's configure script
invokes dpkg!  Yup, you heard that right.  Ok, that's just braindead.
Beyond that, the configure script had problems at the end when trying
to run some commands with some variables that were still set to "".
In particular it ran "set" and later "ln" with missing arguments.
So, I never did get dpkg built, and I didn't want to waste more time
getting into the configure script (this is why I always hated
configure scripts).  Moving on, I tried to use the premade binaries.
I unpacked them, set my PATH and LD_* variables, and was off and
running again.  I had to build a start-stop-daemon program from the
sources and shove it into an sbin dir, but other than that, the premade
bins seemed to be working ok.  Now, I *know* this is a debian project,
but it would be really nice if the instructions accomodated those of
us who aren't using debian linux.  

    fourth complaint: It was never mentioned that dpkg was required,
        or how to get/build it.  Dpkg src needs some work so that it
        can be built on systems other than debian-linux.

Ok, with dpkg set up and running, I was able to run the scripts further
only to find more script problems:

    fifth complaint:  Although the debian linux test/[ program supports
        '==', not all test programs do.  I had to replace == with = in
        the dpkg-hurd script.  In addition, the script did things like
        'if [ ${1} = "-x" ]'.   Oops!  That's bad.  The dash in front of
        the ${1} arg can confuse poor old test.  I changed those type
        tests to 'if [ "x${1}" = "x-x" ]'

Ok, with all of that tweaking done, I was able to successfully run
the cross-install script.  yay!  Of course, afterwards I noticed that
I didn't use the '-o hurd' option when making the ext2fs, so I redid
the mkfs.  I noticed that the instructions called for a different
program, again probably due to debian/redhat differences:

    sixth complaint:  I had to run 'mkfs.e2fs -o hurd /dev/xxx' not
        'mke2fs -o hurd /dev/hdxx'.  The docs should point out that
        the command may be different in different linux distributions.

Ok, so time to boot...  I made a grub floppy, I rebooted, I started
to type in the commands listed in the faq,  uh oh.. when I typed
root=(hd0,7), it didnt work:  "geometry error".  I tried hd(0,x)
for x = 0 through 7.  Partition 0 was recognized as my dos partition
(it didnt know about the fs, but thats ok),  partition 4 was recognized
as my linux partition (linux root), but my linux partition is really
hda5 (first logical partition in the extended partition).  I was not
able to find another ext2fs, even though my hurd partition does exist
at hda7.  So the question is:

   - is grub limited to the first 8gig of the drive?
   - is grub limited to using partitions 1-4?  (and I was just
     lucky with hda5, since its start coincided with the start
     of my extended partition?)

if either of these is true, the FAQ should probably mention these

So anyway,  I could never get the thing booted to do the after-boot
steps.  I could always do some partition shuffling, but I havent
tried anything like that yet.

ok.. I think that's enough from me for now.  :)
hope the feedback is useful, and doesnt sound too much like bitching.

                                        Tim N.

Reply to: