[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Cross compiling doesn't work anymore (was: Re: GNU libc snapshots work again on the Hurd)


>>>>> Marcus Brinkmann writes:

 MB> ld: warning: ld.so.1, needed by /usr/i386-gnu/lib/libc.so.0.2,
 MB> not found (try using --rpath)
 MB> I could fix this by adding '-Xlinker "-rpath=/usr/i386-gnu/lib"'
 MB> to gcc command line. There must be a different solution to this,
 MB> as it worked before.

It only worked before because the linker script explicitly specified
libhurduser/libmachuser, but now they're dragged in by shared library

The correct solution is to add `-Wl,-rpath-link=/usr/i386-gnu/lib' to
the cross-compiler wrapper.  I've changed make-cross to do this... you
can get it from alpha.gnu.org:/gnu/hurd/ghhk/make-cross.

 MB> Gordon, please add the following symlinks to the Debian package,
 MB> they are missing:

 MB> /gnu/lib/libc.so.0.2 -> libc-2.0.106.so
 MB> /gnu/lib/libhurduser.so.0.0 -> libhurduser-2.0.106.so

Thanks, I've already done this...

BTW, I've got access to master.debian.org now, so I can finally upload
packages!  Yippee!

 Gordon Matzigkeit <gord@fig.org> //\ I'm a FIG (http://www.fig.org/)
    Lovers of freedom, unite!     \// I use GNU (http://www.gnu.org/)
[Unfortunately, www.fig.org is broken.  Please stay tuned for details.]

Reply to: