[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: debian-hppa install notes with some CD trouble

Initial locale and language dialogs worked fine, until it came to mounting the
CD-ROM. That failed and asked if I want to load a driver. sr_mod was there so
it was not a module problem. dmesg showed errors about reading past end of device.
So I wrote another CD (checked SHA256sum of the image to make sure) with wodim -pad
to pad the secotrs up. Still same problem.

The logs showed problematic command was
mount -t iso9660 /dev/sr0 /cdrom
So I tried it by hand and it failed with "No such file or directory".

After a manual retry it mounted. I unmounted it an let the installer try again
and this time it worked. Why it worked, remains a mystery for me.

Maybe the "old" CD-ROM drive has hickups ?
I have since tested it in as many ways I could - mounted and unmounted it repeatedly,
tar'ed all the files from it etc. It is slow but always works.

The only CD-related errors in dmesg are in the form of not being able to read past end of device:

[   35.835421] sr 0:0:6:0: [sr0] tag#46 UNKNOWN(0x2003) Result: hostbyte=0x00 driverbyte=0x08
[   35.918389] sr 0:0:6:0: [sr0] tag#46 Sense Key : 0x3 [current]
[   35.973370] sr 0:0:6:0: [sr0] tag#46 ASC=0x6 ASCQ=0x0
[   36.019042] sr 0:0:6:0: [sr0] tag#46 CDB: opcode=0x28 28 00 00 01 9c 2c 00 00 02 00
[   36.094680] print_req_error: I/O error, dev sr0, sector 422064 flags 80700
[   36.164130] attempt to access beyond end of device
[   36.205653] sr0: rw=0, want=422072, limit=422064
[   36.245094] Buffer I/O error on dev sr0, logical block 52758, async page read

# isoinfo -d dev=/dev/sr0
CD-ROM is in ISO 9660 format
System id: LINUX
Volume id: Debian 10.0 hppa n
Volume set id:
Publisher id:
Data preparer id:
Copyright File id:
Abstract File id:
Bibliographic File id:
Volume set size is: 1
Volume set sequence number is: 1
Logical block size is: 2048
Volume size is: 105501
NO Joliet present
Rock Ridge signatures version 1 found

This shows the file system is 105501*4=422004 512-byte sectors in size and
should not cause the accesses beyond end of device.

udev's /lib/udev/cdrom_id does not cause these errors either, at least when I run it.

# wodim -toc
Device was not specified. Trying to find an appropriate drive...
Detected CD-R drive: /dev/cdrw
Using /dev/cdrom of unknown capabilities
Device type    : Removable CD-ROM
Version        : 2
Response Format: 2
Capabilities   : SYNC LINKED
Vendor_info    : 'PLEXTOR '
Identification : 'CD-R   PX-W1210S'
Revision       : '1.00'
Device seems to be: Generic mmc CD-RW.
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P RAW/R96R
first: 1 last 1
track:   1 lba:         0 (        0) 00:02:00 adr: 1 control: 4 mode: 1
track:lout lba:    105518 (   422072) 23:28:68 adr: 1 control: 4 mode: -1

So it seems something else in the boot process tries to read the very end of the CD and fails. But
nothing depends on it in practice.

Sector numbers are strange though - 422072 sectors in tack but 422064 is causing problems - maybe because of Linux doing bigger requests.

dd with bs=2048 reads
105516+0 records in
105516+0 records out
and 105516 < 105518. Why 105516?

Meelis Roos <mroos@linux.ee>

Reply to: