[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

debian-hppa install notes with some CD trouble

I tested debian-ports install on HP 9000 A180c (the last 32-bit server with parisc).

First I needed to find external SCSI CD-ROM with 512-byte block size support -
I managed but netboot images would have been much simpler (same goes for sparc64).

Next, the CD was recognized as bootable by SEARCH IPL, good. It booted too and palo
chose the correct 32-bit kernel and automatically used my serial console too.

Initial locale and language dialogs worked fine, until it came to mounting the
CD-ROM. That failed and asked if I want to load a driver. sr_mod was there so
it was not a module problem. dmesg showed errors about reading past end of device.
So I wrote another CD (checked SHA256sum of the image to make sure) with wodim -pad
to pad the secotrs up. Still same problem.

The logs showed problematic command was
mount -t iso9660 /dev/sr0 /cdrom
So I tried it by hand and it failed with "No such file or directory".

After a manual retry it mounted. I unmounted it an let the installer try again
and this time it worked. Why it worked, remains a mystery for me.

Next stop was at configuring the package manager, after installing base system.
I was greeted with the following dialog where I retried multiple times.

  lqqqqqqqqqqqqqqqqu [!!] Configure the package manager tqqqqqqqqqqqqqqqqqk
   x                                                                       x
  lx /cdrom/:Please insert the disc labeled: 'Debian GNU/Linux 10.0 _Sid_  x
  xx - Unofficial hppa NETINST 20190127-18:59' in the drive '/cdrom/' and  x
  xx press enter.                                                          x
  xx                                                                       x
  xx Media change                                                          x
  xx     <Go Back>                                          <Continue>     x
  xx                                                                       x
This is corresponding log from screen 4 (no I/O errors, just multiple mountings):

Feb 18 11:45:21 apt-setup: Found 1 package indexes, 0 source indexes, 0 translation indexes and 0 signatures
Feb 18 11:45:21 apt-setup: This disc is called:
Feb 18 11:45:21 apt-setup: 'Debian GNU/Linux 10.0 _Sid_ - Unofficial hppa NETINST 20190127-18:59'
Feb 18 11:45:21 apt-setup: Copying package lists...
Feb 18 11:45:21 apt-setup: ^MReading Package Indexes... 0%^M
Feb 18 11:45:21 apt-setup: ^MReading Package Indexes... 0%^M
Feb 18 11:45:23 apt-setup: ^MReading Package Indexes... 241%^M
Feb 18 11:45:23 apt-setup: ^MReading Package Indexes... Done^M
Feb 18 11:45:23 apt-setup:
Feb 18 11:45:23 apt-setup: Writing new source list
Feb 18 11:45:23 apt-setup: Source list entries for this disc are:
Feb 18 11:45:23 apt-setup: deb cdrom:[Debian GNU/Linux 10.0 _Sid_ - Unofficial hppa NETINST 20190127-18:59]/ sid main
Feb 18 11:45:23 apt-setup: Repeat this process for the rest of the CDs in your set.
Feb 18 11:45:26 kernel: [ 7011.291838] ISO 9660 Extensions: RRIP_1991A
Feb 18 11:45:27 kernel: [ 7012.153976] ISO 9660 Extensions: RRIP_1991A
Feb 18 11:47:00 kernel: [ 7105.302931] ISO 9660 Extensions: RRIP_1991A
Feb 18 11:48:19 kernel: [ 7184.826600] ISO 9660 Extensions: RRIP_1991A
Feb 18 12:15:36 kernel: [ 8821.824640] ISO 9660 Extensions: RRIP_1991A

Retrying package manager configuration from the main menu asked me for network mirror
so I provided ftp.ports.debian.org and /debian-ports/ and install could continue.

After installing all the packages (pkgsel works fine), the installer again asks for CD labeled
'Debian GNU/Linux 10.0 _Sid_ - Unofficial hppa NETINST 20190127-18:59'. After choosing
Back, it told something abou finishing installation and then goes back to main menu with
"Finish the installation" selected. Selecting something from there (I think I chose PALO installation)
ejects the CD and tells the installation is finished.

After reboot, SCSI disk becomes valid for IPL and the systems boots up from the hard disk.

The kernel waits a lot after
[   58.632191] random: crng init done
but that was the same during installer bootup.

Finally it boots up fine. zalon7xx gives warnings but that is for another time.

Meelis Roos <mroos@linux.ee>

Reply to: