[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: State of the PA-RISC/HPPA port (August 2013)

On 8/4/13 1:24 PM, John David Anglin wrote:
You have probably seen this howto:

As I mentioned, I had trouble with new scheme.  Possibly, this was
because I created the
partition type as F0 instead of linux 83.  It didn't mount.  I'm
assuming that you are trying to
use the new scheme and it's getting reformatted wiping your kernel and

If you get system running on hard drive, you can install palo with
"apt-get install palo".
You also can probably just copy it from CD.

On 4-Aug-13, at 2:34 PM, Dave Land wrote:

On 8/4/13 9:38 AM, John David Anglin wrote:
On 3-Aug-13, at 11:41 PM, Dave Land wrote:

After talking with Helge off-list, I finally got my box (Visualize
J6750) to boot to the 'real' OS on the HDD, but I'm still working out
some issues with palo, so it will actually find the working root
partition without intervention from me. ;)

The root= parameter mostly works for me.  However, different kernels
sometimes change the order of
disk discovery when you have multiple drives.  Helge thinks it would be
easy to specify file system by
uuid.  This would work well for non recovery situations.  Another
thought is to specify the root partition
by number assuming it has to be on same drive as boot kernel.

When booting from the lifimage CD, in the IPL list, 'root=/dev/sda3'
would actually get me into the 'real' file system as long as I dropped
that line into where the 'ramdisk=xxxx' entry was, and removed the #2
entry I think.. (bootip=bootp), so it would read the CD instead of
looking for a tftp server.

I have an inexpensive portable USB drive connected to one of my
systems.  It comes up as /dev/sda
at boot and messes up the drive order.  Not exactly plug and play...

LOL, ain't that the truth...

After a kernel decides which drive order to use, I boot manually setting
root=/dev/sdXY to the correct
drive and partition.  Then, I edit /etc/palo.conf to correct the root
setting and rerun palo.  One can use
the palo -f option to specify a specific conf file if one has multiple
boot drives.

If I can get people to leave me alone for a while today, I'll work on
the /etc/palo.conf file, and see if I can possibly get it to re-write
the file with palo -f. The problem I run into was, once I would use
apt-get (in the 'real' FS on the hard disc), to get and install the 64
bit linux-image package, it would disappear from /boot when I had to
go back and boot from the CD image to have access to the 'palo' command.

(I may be missing something, but palo doesn't seem to be accessible on
the 'real' file system for reasons I haven't discovered yet.)

Booting from CD, under Busybox, I had to mount /dev/sda3 file system
at /mnt/destroot... and Helge suggested also mounting /dev/sda2 as
/mnt/destroot/boot so palo -f would 'see' the proper boot partition
with the kernel images, but since the 64 bit image seemed to have
disappeared from /boot after I re-mounted everything, of course palo
errored out again, because it couldn't find the file.

I need to research why I can't run/find palo in the real file system,
so everything is where it's supposed to be when I try to execute the
appropriate palo command(s). I'm sure once I get that accomplished, it
should boot successfully without outside intervention from me.

One thing I did notice is, once I actually got it to boot to the file
system on the HDD, it was about twice as fast as it ever was with
Lenny. This gives me hope. :))

I'm not sure the "new" ext2/ext3 scheme described on the wiki works.  I
tried it yesterday.  After running
the palo command to make a filesystem on the F0 partition, I wasn't able
to mount it.  So, I went back to
old hidden partition scheme.

There is a small bug decompressing gzipped kernels.  I see error message
at end of process but it
doesn't seem to affect the boot.  This cuts kernel size by about 1/3.

John David Anglin    dave.anglin@bell.net

Dave, Basically having the same issue here...

Here's the error msg. and the backtrace:

VFS: Cannot open root device "(null)" or unknown-block(0,)): error -6
Please append a correct "root=" boot option; here are the available partitions:

0300       20654 hda driver: ide-cdrom
0810    35566480 sdb driver: sd
0800    35566480 sda driver: sd
 0801     289138 sda1 e3470600-01   #palo/boot#
 0802    3903795 sda2 e3470600-02   #swap#
 0803   31366912 sda3 e3470600-03   #/#

##The text between ##, I added in for the sake of clarity. Dave Land##

Kernel panic - not syncing: VFS: Unable to mount root fs on uknown-block(0,0)
CPU: 1PID: 1 Comm: swapper/0 Not tainted 3.10.0-32Bit+ #4

[<10115cfc>] show_stack+0x18/0x28
[<103082f8>] dump_stack+0x28/0x38
[<10130374>] panic+0xd4/0x2a0
[<1075a6c8>] mount_block_root+0x228/0x2ec
[<1075a910>] mount_root+0x68/0x80
[<1075aad0>] prepare_namespace+0x1a8/0x1e8
[<1075a298>] kernel_init_freeable+0x234/0x270
[<10108b34>] kernel_init+0x1c/0x114
[<1010401c>] end_fault_vector+0x1c/0x24
[<1013d21c>] proc_dointvec_minmax+0x0/0x70


I tried a mixture of the install instructions on the parisc.org site and the updated palo config instructions from tldp.org, and used just 3 partitions (palo/boot (f0) swap (swap) and sda3 formatted as ext3fs) Using a combination of the palo command line from both, I came up with this for the initial palo install from CD: palo --format-as=3 init-partitioned=/dev/sda --commandline=1/boot/vmlinux64 root=/dev/sda3 HOME=/

I then mounted /dev/sda3 on /mnt/destroot/ and mounted /dev/sda1 on /mnt/destroot/palo and did the debootstrap from parisc-linux.org. Once that finished, I moved the contents of the /mnt/destroot/boot directory to /mnt/destroot/palo (essentially /dev/sda1). I then had to umount /dev/sda1 and /dev/sda3 and ran the palo command again, (and since it only installed the 32bit+ kernel once again), I did it like this: palo --update-partitioned=/dev/sda --format-as=3 --commandline=1/vmlinuz-3.10.0-32bit+ root=/dev/sda3 HOME=/ I re-mounted /dev/sda1 as /mnt/destroot/palo/ and made sure the files were still there, and then umounted it..

Then I re-booted and everything went fine until it got to the part above where it tried to mount the root filesystem, and did a kernel panic. Why it won't mount the root fs is beyond me. Everything *looks* right in the palo configuration, but something's not happening the way it should. Hopefully this might help you troubleshoot this a bit more.

I can still boot into the 'real' file system on the HDD, if I boot from the CD and add "root=/dev/sda3" to the palo IPL list. It comes up with a login prompt and all, but I can't login unless I go in from the CD, mount /dev/sda3, and edit /etc/passwd and /etc/shadow and kill the p/w for the root entry, and then reboot and login as root & set a new password.

Dave Land
Land Computer Service

Check out my site at http://www.landcomp.net

Reply to: