[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: State of the PA-RISC/HPPA port (August 2013)

On 8/4/13 9:38 AM, John David Anglin wrote:
On 3-Aug-13, at 11:41 PM, Dave Land wrote:

After talking with Helge off-list, I finally got my box (Visualize
J6750) to boot to the 'real' OS on the HDD, but I'm still working out
some issues with palo, so it will actually find the working root
partition without intervention from me. ;)

The root= parameter mostly works for me.  However, different kernels
sometimes change the order of
disk discovery when you have multiple drives.  Helge thinks it would be
easy to specify file system by
uuid.  This would work well for non recovery situations.  Another
thought is to specify the root partition
by number assuming it has to be on same drive as boot kernel.

When booting from the lifimage CD, in the IPL list, 'root=/dev/sda3' would actually get me into the 'real' file system as long as I dropped that line into where the 'ramdisk=xxxx' entry was, and removed the #2 entry I think.. (bootip=bootp), so it would read the CD instead of looking for a tftp server.

I have an inexpensive portable USB drive connected to one of my
systems.  It comes up as /dev/sda
at boot and messes up the drive order.  Not exactly plug and play...

LOL, ain't that the truth...

After a kernel decides which drive order to use, I boot manually setting
root=/dev/sdXY to the correct
drive and partition.  Then, I edit /etc/palo.conf to correct the root
setting and rerun palo.  One can use
the palo -f option to specify a specific conf file if one has multiple
boot drives.

If I can get people to leave me alone for a while today, I'll work on the /etc/palo.conf file, and see if I can possibly get it to re-write the file with palo -f. The problem I run into was, once I would use apt-get (in the 'real' FS on the hard disc), to get and install the 64 bit linux-image package, it would disappear from /boot when I had to go back and boot from the CD image to have access to the 'palo' command.

(I may be missing something, but palo doesn't seem to be accessible on the 'real' file system for reasons I haven't discovered yet.)

Booting from CD, under Busybox, I had to mount /dev/sda3 file system at /mnt/destroot... and Helge suggested also mounting /dev/sda2 as /mnt/destroot/boot so palo -f would 'see' the proper boot partition with the kernel images, but since the 64 bit image seemed to have disappeared from /boot after I re-mounted everything, of course palo errored out again, because it couldn't find the file.

I need to research why I can't run/find palo in the real file system, so everything is where it's supposed to be when I try to execute the appropriate palo command(s). I'm sure once I get that accomplished, it should boot successfully without outside intervention from me.

One thing I did notice is, once I actually got it to boot to the file system on the HDD, it was about twice as fast as it ever was with Lenny. This gives me hope. :))

I'm not sure the "new" ext2/ext3 scheme described on the wiki works.  I
tried it yesterday.  After running
the palo command to make a filesystem on the F0 partition, I wasn't able
to mount it.  So, I went back to
old hidden partition scheme.

There is a small bug decompressing gzipped kernels.  I see error message
at end of process but it
doesn't seem to affect the boot.  This cuts kernel size by about 1/3.

John David Anglin    dave.anglin@bell.net

Dave Land
Land Computer Service

Check out my site at http://www.landcomp.net

Reply to: