[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Fwd: Re: Two problems on C3000 with latest 2.6.x autobuild kernel

Date: Tue, 24 May 2005 12:51:27 +0800
To: "Erik Heckers" <erik.heckers@web.de>
From: "J. L. Lee" <jllee@singnet.com.sg>
Subject: Re: Two problems on C3000 with latest 2.6.x autobuild kernel

Hi Erik,

On Problem B - (Don't know exactly I am using RC2 or RC3, how to tell? I am using 2.6.8-2.32 kernel built on 17 May on an HP 9000/785/B2000).

I too came across the same Kernel panic msg. I overcame it by mounting the CD-ROM to /cdrom or /media/cdrom or /media/cdrom0. There is no /mnt although you can see it when you list the root directory - "ls /". But if you do a '"ls -l /mnt" you get "No such file or directory" msg.


At 01:50 AM 5/24/2005 +0200, you wrote:

I have installed my C3000 using the RC2 version of sarge (netinst iso-image).
[RC3 didn't work, kernel hangs at sym0: scsi driver, see this mailing list ...]

I wanted to upgrade to the latest 2.6.x kernel to see if the SCSI problems of the
RC3 kernel (2.6.8) are solved.

So I have installed the following  prebuild 'c3000' kernel:

I'm experiencing two problems with this kernel:

### Problem A
Cannot login on local console(s) (tty1,tty2,...,tty6)

I have also enabled ttyS0 which works (serial cable to another PC).
When I restart getty on tty1 I get a new login on tty1, so I think the problem is that the
input of my USB keyboard is ignored somehow.
According to the 'dmesg' output everything looks ok, the output tells me that the
keyboard is correctly detected as a USB-HID device.
(I tried a non-HP USB keyboard with the same result...)

Is there anything else I have to change to make a USB keyboard work with a 2.6.x kernel?

When using the old RC2-2.4.x kernel I can do a 'cat /dev/input/eventX' and get some
garbage when pressing the buttons on the USB keyboard - looks good.
But when using the 2.6.12-rc4 kernel I get some message like '/dev/input/eventX - no such device'. (I currently cannot give you the exact error message because of problem B ...).

### Problem B
A simple
mount /dev/hda /mnt
causes a kernel panic.
/dev/hda is my IDE-CD drive. As far as I have seen the support for IDE-CD is built into the kernel.
(Again it works fine with RC2-2.4.x  kernel)

Are there any known issues with missing a '2.4.x environment' with a 2.6.x kernel, so the errors are somehow related to my setup and the kernel is the wrong one to blame here?


--- what I have written end exactly here, rest comes from my freemail service ---

Mit WEB.DE FreePhone mit hoechster Qualitaet ab 0 Ct./Min.
weltweit telefonieren! http://freephone.web.de/?mc=021201

To UNSUBSCRIBE, email to debian-hppa-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: