[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFC and status report: Kernel upgrades for woody->sarge upgrades

On Thu, Mar 24, 2005 at 02:08:25PM -0800, Steve Langasek wrote:
> On Thu, Mar 24, 2005 at 01:54:38PM +0000, Matthew Wilcox wrote:
> > On Thu, Mar 24, 2005 at 02:31:55PM +0100, Frank Lichtenheld wrote:
> > > As many of you may know on some machines users will need to install
> > > a current kernel before they will be able to upgrade woody to sarge
> > > (or better: glibc of woody to glibc of sarge). I've tried to use the
> > > available information to provide the needed files for these kernel
> > > upgrades.
> > > To my knowledge the affected machines/architecures are currently
> > > hppa64, sparc sun4m (only some of them) and 80386.
> > It's all hppa machines, not just hppa64.
> Then why does the libc6 preinst say that the minimum kernel is 2.4.17 for
> parisc, and 2.4.19 for parisc64?  If this is an error, it will need to be
> reconciled before release.

It is not an error. I submitted the patch. Userspace requires a 32-bit
kernel of atleast 2.4.17, and a 64-bit kernel of atleast 2.4.19. The
64-bit code has some orthogonal issues that took time to fix.

Both could be made to require 2.4.19, and infact the upstream glibc
patch set the requirement to 2.4.19.


Reply to: