[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: [parisc-linux] Booting 2.6


	Boy, you have a long memory ... back to a year ago when I responded without
copying parisc-linux. No need to worry, I learned that lesson :-). I'm also
copying debian-hppa, which I hope is a good thing (but I'm open to
correction if not).

	Yes, I tried initrd=1/boot/initrd.img with everything else the same. I have
attached the console output.

	On my first SCSI drive, there is a 70MB partition that gets mounted as
/BOOT where all of the images are, then there is a swap partition and then /
starts. Thanks again for your help.

Best regards,


-----Original Message-----
From: Grant Grundler [mailto:grundler@parisc-linux.org]
Sent: Wednesday, February 23, 2005 6:11 PM
To: Harry Cochran
Cc: parisc-linux@lists.parisc-linux.org
Subject: Re: [parisc-linux] Booting 2.6

please keep the parisc-linux cc'd.
Others may be able to further help you.

On Wed, Feb 23, 2005 at 05:12:48PM -0500, Harry Cochran wrote:
> Thanks Grant,
> 	I made it 1/boot/initrd.img and I deleted the
>  initrd=/boot/initrd.img line.

I'm hoping you mean: initrd=1/boot/initrd.img

> Same result.

Erm, can you capture and post the console output? (ALL of it)
I'm assuming you have a serial console.
Starting from firmware (BCH) prompt.

> 	My root is still sda3,

"sda" is a dynamic name that gets assigned on every boot.
Change the kernel or the disk configuration and things will get
scrambled if one is not really, really, really careful.

>  but it looks to me like it's not mounted when 2.6
> gets to the kernel panic. That's why I think I need a ramdisk to get the
> standard 2.6 kernel booted. All I have to work with is ash, and I can't
> my /boot (sda1) when I boot off of the cd. Is there any work around you
> think of?

the CD will not auto-mount /boot or /.
And it is likely your disk has /boot as part of /.
This is OK as long as the root disk does NOT cross
of the 2GB boundary from the start of the disk.
See palo help file for more details.

Main Menu: Enter command > bo pri
Interact with IPL (Y, N, Q)?> y

Boot IO Dependent Code (IODC) revision 0

HARD Booted.
palo ipl 1.5 root@c3k Tue Sep 21 15:14:05 MDT 2004

Partition Start(MB) End(MB) Id Type
1               1      31   f0 Palo
2              32    1008   82 swap
3            1009   17366   83 ext2

PALO(F0) partition contains:
    0/vmlinux32 4968722 bytes @ 0x44000

Information: No console specified on kernel command line. This is normal.
PALO will choose the console currently used by firmware (serial).Current command
1/boot/vmlinux root=/dev/sda3 HOME=/ initrd=/initrd.img console=ttyS0 TERM=vt102
 0: 1/boot/vmlinux
 1: root=/dev/sda3
 2: HOME=/
 3: initrd=/initrd.img
 4: console=ttyS0
 5: TERM=vt102

<#>    edit the numbered field
'b'    boot with this command line
'r'    restore command line
'l'    list dir
? 03
Current command line:
1/boot/vmlinux root=/dev/sda3 HOME=/ initrd=1/boot/initrd.img console=ttyS0 TERM
 0: 1/boot/vmlinux
 1: root=/dev/sda3
 2: HOME=/
 3: initrd=1/boot/initrd.img
 4: console=ttyS0
 5: TERM=vt102

<#>    edit the numbered field
'b'    boot with this command line
'r'    restore command line
'l'    list dir
? b

Command line for kernel: 'root=/dev/sda3 HOME=/ console=ttyS0 TERM=vt102 palo_ke
Selected kernel: /boot/vmlinux from partition 1
Selected ramdisk: /boot/initrd.img from partition 1
Warning: kernel name doesn't end with 32 or 64 -- Guessing...
This box can boot either 32 or 64-bit kernels...Only see a 32-bit kernel, using
thatELF32 executable
Entry 00100000 first 00100000 n 3
Segment 0 load 00100000 size 2832408 mediaptr 0x1000
Segment 1 load 003b4000 size 705472 mediaptr 0x2b5000
Segment 2 load 00464000 size 397328 mediaptr 0x362000
ERROR: failed to load ramdisk - proceeding anywayBranching to kernel entry point
 0x00100000.  If this is the last
message you see, you may need to switch your console.  This is
a common symptom -- search the FAQ and mailing list at parisc-linux.org

Linux version 2.6.8-2-32-smp (kyle@caradhras) (gcc version 3.3.5 (Debian 1:3.3.5
-7)) #1 SMP Mon Feb 7 22:19:10 EST 2005
FP[0] enabled: Rev 1 Model 16
The 32-bit Kernel has started...
Determining PDC firmware type: System Map.
model 00005d40 00000491 00000000 00000002 782e91ff 100000f0 00000008 000000b2 00
vers  00000301
CPUID vers 17 rev 11 (0x0000022b)
capabilities 0x3
model 9000/785/J6000
Total Memory: 2048 Mb
LCD display at f05d0008,f05d0000 registered
SMP: bootstrap CPU ID is 0
Built 1 zonelists
Kernel command line: root=/dev/sda3 HOME=/ console=ttyS0 TERM=vt102 palo_kernel=
PID hash table entries: 16 (order 4: 128 bytes)
Console: colour dummy device 160x64
Dentry cache hash table entries: 524288 (order: 9, 2097152 bytes)
Inode-cache hash table entries: 262144 (order: 8, 1048576 bytes)
Memory: 2097152k available
Calibrating delay loop... 1101.00 BogoMIPS
Security Scaffold v1.0.0 initialized
Capability LSM initialized
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
Brought up 1 CPUs
NET: Registered protocol family 16
EISA bus registered
Searching for devices...
Found devices:
1. Astro BC Runway Port at 0xfed00000 [10] { 12, 0x0, 0x582, 0x0000b }
2. Elroy PCI Bridge at 0xfed30000 [10/0] { 13, 0x0, 0x782, 0x0000a }
3. Elroy PCI Bridge at 0xfed34000 [10/2] { 13, 0x0, 0x782, 0x0000a }
4. Elroy PCI Bridge at 0xfed38000 [10/4] { 13, 0x0, 0x782, 0x0000a }
5. Elroy PCI Bridge at 0xfed3c000 [10/6] { 13, 0x0, 0x782, 0x0000a }
6. Duet W+ at 0xfffa0000 [32] { 0, 0x0, 0x5d4, 0x00004 }
7. Duet W+ at 0xfffa2000 [34] { 0, 0x0, 0x5d4, 0x00004 }
8. Memory at 0xfed10200 [49] { 1, 0x0, 0x00a, 0x00009 }
Releasing cpu 1 now, hpa=fffa2000
FP[1] enabled: Rev 1 Model 16
CPU(s): 2 x PA8600 (PCX-W+) at 552.000000 MHz
SBA found Astro 2.1 at 0xfed00000
lba version TR4.0 (0x5) found at 0xfed30000
PCI: Enabled native mode for NS87415 (pif=0x8f)
lba version TR4.0 (0x5) found at 0xfed34000
lba version TR4.0 (0x5) found at 0xfed38000
lba version TR4.0 (0x5) found at 0xfed3c000
SCSI subsystem initialized
TC classifier action (bugs to netdev@oss.sgi.com cc hadi@cyberus.ca)
STI GSC/PCI core graphics driver Version 0.9a
unwind_init: start = 0x103b5720, end = 0x103d6f20, entries = 8576
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
devfs: 2004-01-31 Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x0
Initializing Cryptographic API
SuperIO: Found NS87560 Legacy I/O device at 0000:00:0e.1 (IRQ 64)
SuperIO: Serial port 1 at 0x3f8
SuperIO: Serial port 2 at 0x2f8
SuperIO: Parallel port at 0x378
SuperIO: Floppy controller at 0x3f0
SuperIO: ACPI at 0x7e0
SuperIO: USB regulator enabled
Soft power switch enabled, polling @ 0xf0400804.
Generic RTC Driver v1.07
Serial: 8250/16550 driver $Revision: 1.90 $ 25 ports, IRQ sharing enabled
ttyS0 at I/O 0x3f8 (irq = 99) is a 16550A
ttyS1 at I/O 0x2f8 (irq = 100) is a 16550A
RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
mice: PS/2 mouse device common for all mice
HP SDC: No SDC found.
HP SDC MLC: Registering the System Domain Controller's HIL MLC.
HP SDC MLC: Request for raw HIL ISR hook denied
NET: Registered protocol family 2
IP: routing cache hash table of 4096 buckets, 96Kbytes
TCP: Hash tables configured (established 131072 bind 52428)
Root-NFS: No NFS server available, giving up.
VFS: Unable to mount root fs via NFS, trying floppy.
VFS: Cannot open root device "sda3" or unknown-block(2,0)
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on unknown-block(2,0)

Reply to: