[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Sparc headers eh?


Curious Question:

I'm running 2.4.9-pa20 on 712/60, that was installed from a baseplus
tarball and then apt-get dist-upgraded to the latest everything.

When apt-get'ing the kernel headers required to dpkg-buildpackage the 
latest glibc source, I get the odd situation:

root@sonn:~/glibc_build/glibc-2.2.4# apt-get install kernel-headers-2.4
Reading Package Lists... Done
Building Dependency Tree... Done
Note, selecting kernel-headers-2.4.9-sparc instead of kernel-headers-2.4
The following NEW packages will be installed:
0 packages upgraded, 1 newly installed, 0 to remove and 0  not upgraded.
Need to get 0B/1429kB of archives. After unpacking 9187kB will be used.
Selecting previously deselected package kernel-headers-2.4.9-sparc.
(Reading database ... 18467 files and directories currently installed.)
Unpacking kernel-headers-2.4.9-sparc (from .../kernel-headers-2.4.9-sparc_16_all.deb) ...
Setting up kernel-headers-2.4.9-sparc (16) ...


"-sparc"? Cheese?

I've run "apt-get update" and had no luck with getting the proper 
kernel headers.

Anyone else run into this problem?

I've worked around it, but was just hoping to fix the issue (since it
may eventually lead to other strange problems on my end).

If you need help, just ask away!


Reply to: