[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

update the package plan

Hello, I will try to work on package plan today, and I would like to help with the experimental branch

so I ran the ./test-package.pl whcih end up with this error.

Cabal install failed:
Warning: the --global flag is deprecated -- it is generally considered a bad
idea to install packages into the global store
cabal: Could not resolve dependencies:
[__0] next goal: bindings-nettle (user goal)
[__0] rejecting: bindings-nettle-0.4 (conflict: pkg-config package nettle-any,
not found in the pkg-config database)
[__0] rejecting: bindings-nettle-0.3.1, bindings-nettle-0.3,
bindings-nettle-0.2, bindings-nettle-0.1.1, bindings-nettle-0.1,
bindings-nettle-0.0 (constraint from command line flag requires (==0.4))
[__0] fail (backjumping, conflict set: bindings-nettle)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: bindings-nettle

should I undertand that it failed because it can not find the pkg-config dependency  nettle  with pkg-config.

and what is the proper way to fix this issue.

thanks for your help


Reply to: