[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Dh_Haskell's configure recipe datasubdir


Am Samstag, den 30.05.2015, 19:32 +0200 schrieb Iustin Pop:
> I see that Dh_Haskell's configure_recipe pases this to the configure:
>         --datasubdir=${CABAL_PACKAGE}
> If I understand things correctly, without overriding datadir, this
> results in Haskell packages using paths directly under /usr/share
> based on the cabal package name, which is the not the debian package
> name, hence /usr/share mixes two namespaces.
> Normally it might not be a problem, but for some Cabal packages with
> common names like js-jquery, it means we steal or conflict on a very
> generic name.
> Does anyone know the rational of using CABAL_PACKAGE instead of the
> actual package name (which should prevent any conflicts)?

the rationale of that flag is to not encode the version number in the
path. For most packages, using the Cabal name is the right thing, as
most packages that ship such files have non-generic names (shake,
pandoc, hlint).

If we have packages with a generic cabal name that put stuff there then
we need to extend haskell-devscript to allow us to change that flat.
Patch welcome :-)


Joachim "nomeata" Breitner
Debian Developer
  nomeata@debian.org | ICQ# 74513189 | GPG-Keyid: F0FBF51F
  JID: nomeata@joachim-breitner.de | http://people.debian.org/~nomeata

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: