[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: State of Haskell on sparc?

Le 30/04/2014 09:36, Joachim Breitner a écrit :

Am Dienstag, den 29.04.2014, 16:27 +0200 schrieb Joachim Breitner:
According to "dak rm -R -n haskell-tls-extra" this blocked by left over
packages depending on it on sparc. The root of the cause is a failure of
haskell-tls to build on sparc:

The build fails in the test suite with a “Bus error” – nothing that I
can easily debug.

just a small update into the larger round: Patrick Baggett has created a
patch (thanks!) and I applied it to the haskell-cryptohash package
(where the buggy C code was). Unfortunately, we cannot test this as
libgmp-dev is uninstallable on sparc:

haskell-cryptohash build-depends on:
- ghc
ghc depends on:
- libgmp-dev
libgmp-dev depends on:
- libgmpxx4ldbl (= 2:6.0.0+dfsg-2)
libgmpxx4ldbl depends on:
- libstdc++6 (>= 4.4.0)
libstdc++6 depends on missing:
- gcc-4.8-base (= 4.8.2-19)


What is going on here? Do I have to rebuild ghc or is it a general
Problem? Is this on someone’s monitor?


Indeed, you're hitting a bug I've been tracking for 3 days.
Something changed in the gcc-4.8 build and it doesn't generate the libgcc and libstdc++ build which are required for a lot of package.

I'm looking after this.

S. Bernard

Reply to: