[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dbus testsuite and old QuickCheck

I've removed the upper bound; the test suite doesn't do anything
super-fancy with QuickCheck, and I've verified that it works on modern
versions. Since this is a tests-only change, I've pushed it to git but
I'm not planning to cut a release just for this.

You'll need chell-quickcheck==0.2.3 to build against QuickCheck 2.7.x,
since there were some changes to the QC API from 2.6->2.7.

On Sun, Apr 13, 2014 at 6:32 PM, Clint Adams <clint@debian.org> wrote:
> The QuickCheck == 2.4.* dependency seems rather strict; could you
> loosen or drop the upper bound?

Reply to: