[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: New build problems on amd64


On 12/03/2011 15:26, Joachim Breitner wrote:
> Hi,
> Am Samstag, den 12.03.2011, 11:23 +0530 schrieb Joachim Breitner:
>> Unfortunately, a new build error comes up with amd64. It might be
>> related to building with parallel=2. But when I gave it back once, the
>> same error occurred, so it is likely to be reproducible. Can someone
>> have a look:
>> https://buildd.debian.org/build.php?pkg=ghc&arch=amd64&ver=7.0.2-4
> I tried to build it in a amd64 chroot with parallel=2, works like a
> charm. Any further input welcome.

Also my build finished correctly (but was without parallel=2).

Looking more closer at the failing build log, the problem doesn't really
seem to be related with the parallel level. The failing piece in the
first build attempt is:

> "inplace/bin/ghc-cabal" configure --with-ghc="/build/buildd-ghc_7.0.2-4-amd64-GUR5Lm/ghc-7.0.2/inplace/bin/dummy-ghc" --with-ghc-pkg="/build/buildd-ghc_7.0.2-4-amd64-GUR5Lm/ghc-7.0.2/inplace/bin/ghc-pkg" --with-gcc="/usr/bin/gcc" --configure-option=--with-cc="/usr/bin/gcc"  --enable-library-profiling --enable-shared --enable-library-for-ghci --configure-option=CFLAGS=" -fno-stack-protector  " --configure-option=LDFLAGS="   " --configure-option=CPPFLAGS="   " -- dist-install libraries/integer-gmp
> Configuring integer-gmp-
> configure: WARNING: unrecognized options: --with-compiler, --with-gcc
> exec: 1684: : Permission denied
> make[2]: *** [libraries/integer-gmp/dist-install/package-data.mk] Error 126
> make[2]: *** Waiting for unfinished jobs....

(it's the same in the second build attempt, but it is scattered across
multiple different lines because in the meantime the other thread
produced some output)

Comparing with my log, at that point the build process should call the
autotool configure script. I don't know why it doesn't work and says
"Permission denied".

$ rm -f prova ; touch prova
$ dash -c 'exec ./prova'
exec: 1: ./prova: Permission denied

According to some search on dash codebase, it appears that the number
just after "exec:" is the line number where the error occurred.

Well, I'm tired now, so I'm going to sleep. I'll try to investigate
better tomorrow.

Ciao, Giovanni.
Giovanni Mascellani <mascellani@poisson.phc.unipi.it>
Pisa, Italy

Web: http://poisson.phc.unipi.it/~mascellani
Jabber: g.mascellani@jabber.org / giovanni@elabor.homelinux.org

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: