[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#535967: Inconsistent state after removal.

Package: haskell-devscripts
Version: 0.6.15+nmu11
Severity: normal


I built network from hackage and installed with --user
--prefix=$HOME/.cabal.  Then, I tried to remove libghc6-parsec3-dev,
which is a dependency of my home built network.  So I got this message:

ghc-pkg: unregistering parsec-3.0.0 would break the following packages:
network- (use --force to override)

but the package was removed nicely.  So I tried to build network again,
and I got:

Preprocessing library network-
Building network-

    Could not find module `Text.ParserCombinators.Parsec':
      There are files missing in the `parsec-3.0.0' package,
      try running 'ghc-pkg check'.
      Use -v to see a list of the files searched for.

I think this is a bug in our prerm script.  But I'm not sure what's the best
way to fix it.  If we use --force, the user installed package will become
inconsistent.  The other option is to exit with error in the prerm script in
such cases, but I'm not sure is a good option either.

What do you think?


-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.29-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=pt_BR.UTF-8, LC_CTYPE=pt_BR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages haskell-devscripts depends on:
ii  cdbs                          0.4.56     common build system for Debian pac
ii  dctrl-tools                   2.13.1     Command-line tools to process Debi
ii  debhelper                     7.2.14     helper programs for debian/rules
ii  ghc6                          6.10.3-2   GHC - the Glasgow Haskell Compilat
ii  html-xml-utils                5.3-3      HTML and XML manipulation utilitie
ii  xutils-dev                    1:7.4+4    X Window System utility programs f

haskell-devscripts recommends no packages.

haskell-devscripts suggests no packages.

-- no debconf information

Reply to: