[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Packaging GNOME 2.7

Le ven, 18/06/2004 à 22:37 -0300, Gustavo Noronha Silva a écrit :

> I don't understand. seb128 is not happy with your email, with
> packaging gnome2.7, with the svn structure you proposed? 

I'm happy with the GNOME 2.7 packaging, I was just saying the way to
announce it was not verbose enough.

Just to be clear:

* We need to be *really* carreful with 2.7 uploads, at this point with
sarge problems we have to avoid *all* the errors (no way to start
uploading broken stuffs in unstable or it will be a real mess for sarge)

* So everybody should test and *use* the wrapper written by HE. It
contains a list of unstable versions (ie: libgnome is 2.6) and catch
wrong upload ... for example if your try to upload a libgnome 2.7.1-1 in
unstable it will stop the upload with something like "unstable has 2.6
branch, you're probably using the wrong target". The wrapper should also
catch 2.6 uploads linked with 2.7 stuffs.

* Ok, most of decisions on the packaging for GNOME are discussed on IRC,
but some people don't use it, and I don't like to take final decisions
without asking on the list what people think/if somebody has some
remark, objections ...

* And finally, some GNOME 2.7 packages are probably not team packages,
so I'd like to know if their maintainers want to work with us on 2.7, or
if they are ok with GNOME Team uploads in experimental.

It hope all this is clear :)


Sebastien Bacher

Reply to: