[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: messed up my system, please need help!

On Sun, 2004-05-30 at 18:33 +0200, p80 wrote:
> all my gnome packages fail to install because of this error:
> /var/lib/dpkg/info/libgnome2-common.postinst: line 28: 18203 Segmentation 
> fault      HOME=/root GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source` 
> gconftool-2 --makefile-install-rule /etc/gconf/schemas/$FILES >/dev/null
> plus now lots of apps that use gnome libs fail to start even kde ones
> how can i fix this?

Please file a bug against "gconftool-2" using "reportbug" so that the
maintainers can see exactly what set of shared library versions
gconftool-2 is linked against on your particular system.  "reportbug"
will gather that list automatically, and the bug tracking system will
create a ticket thread on which to discuss this particular problem.  Be
sure to read the bug headers it returns on starting, to see if the
problem has already been reported.

I had a similar problem a while back with one of the tools run by Gnome
postinst scripts, and it turned out to be caused by an old version of
libxml2.  After upgrading that to a newer release, the problem went
away.  If you try this, please don't do it until after you generate the
bug report, so they can see what version triggered the bug; in case
that's what it is.  It may need version dependencies tightened up.

Karl Hegbloom <hegbloom@pdx.edu>

Reply to: