[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gnome 2 settings

On Tue, 2002-10-29 at 16:57, Miles Bader wrote:

> As far as I could tell, _none_ of my settings were preserved, and I got all
> the defaults (I suppose some were, but they weren't the visually obvious
> ones!).
> I think much of this might be due the conversion script not finishing, so I'm
> not sure whether it's worth going into tons of detail (but I'll try a bit
> anyway).

Yes, that is very likely the case.  If the conversion script fails, and
you log out and log back in again, you will just get the default GNOME 2
desktop.  No further attempt at conversion will be made.

If you want to try again, just do: 
rm -rf ~/.gnome2
gconftool-2 --recursive-unset /apps
gconftool-2 --recursive-unset /desktop
gconftool-2 --recursive-unset /system
>   * The panels I got bore no resemblance to what I had before; in particular,
>     before I had 3 corner panels of various sizes, in the NW, SE, and SW
>     corners, with launchers, applets, etc.  Afterwards, I had just a top-edge
>     `menu panel' (don't want that), and a bottom-edge panel with just a
>     task-list and a `window nav' (don't know the name) applet.

I'll need to see your .gnome directory.  Some of the panel settings
aren't possible to transition (GNOME 2 doesn't have aligned panels).  So
it may be best for you to just discard the transition and start over.

I personally had a very highly customized GNOME 1.4 setup.  You know
what I found though when I switched over to GNOME 2?  I found the
default setup was just very *usable* out of the box.  I didn't need to
do much in the way of tweaking to be very satisfied with the experience.

>     I think some of the applets I used to use weren't included with gnome2,
>     so that might explain some things (and the gnome-applets [?] package
>     didn't get upgraded until the _next_ time I ran aptitude, for some
>     reason, though it didn't show up as broken or held the first time),
>     though not the launchers.

That could also explain it.  The panel might remove applets which don't

>   * My background image wasn't preserved.

This was a silly bug, now fixed in CVS.
>   * None of my gnome-terminal settings seem to have been preserved (roughly:
>     colors, scroll-bar pos, menu-bar-hidden).

I just tested the menu bar and scroll bar preferences; they were
transitioned correctly.  The colors didn't seem to be, but it looks a
bit complex for me to try to fix right now.

>   * Some `general' UI settings weren't preserved; the only one I remember
>     right now is that before I had `icons only' for task-bars, and afterwards
>     I had icons&text.

task-bars?  I'm not sure what you mean here.  

>   * At first it seemed to have tried to preserve my theme, but failed -- it
>     was really wierd, widgets seem to be randomly using either my old dark
>     theme or the default light-background theme.  I tried to use the
>     control-center to change it, but that didn't appear to work; later I
>     realized this was because I had a `.gtkrc-2.0' file that pointed to my
>     old gnome1 theme (I needed this before for gnome-terminal, which was
>     updated to 2.0 before everything else), and that some things were using
>     that, and some things were using the default theme.

Ok, I don't know enough about themeing to say anything useful here.

>     Deleting the file and using the control-center to change things
>     "properly" fixed this.  [BTW, the desktop icon that's supposed to invoke
>     gnomecc didn't work, because there was no program called `gnomecc' --
>     only `gnome-control-center']

This is one thing that I explicitly made sure to fix.  It should have
replaced all .desktop files which had Exec=gnomecc with a .desktop file
which does Exec=nautilus preferences://

If this didn't work, I need to see your ~/.gnome2/debian-upgrade.log and
your .gnome dir.

>   * My start-up settings weren't preserved:  before I _didn't_ run the
>     `desktop' program, but afterwards I got nautilus doing that; also before
>     I had an entry that ran `xrdb', which wasn't preserved.

I am strongly suspecting now that you just got the default GNOME 2

> Well, that's all that comes to mind right now; if I remember anything else
> that seems important I'll send a followup.

Thanks a lot for your feedback.  I hope we can try to resolve most of
the issues you found.

Reply to: