[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#861518: libc6-dev: The newest libc6-dev (2.24-10) badly depends on kernel, particularly linux-libc-dev (>= 4.9.18-1)

control: tag -1 + moreinfo

On 2017-04-29 18:49, Laci Tele wrote:
> Package: libc6-dev
> Version: 2.24-10
> Severity: important
> Dear Maintainer,
>    * What led up to the situation?
> I tried to install libc6-dev on my armhf embedded hardware.
> Its not possible, because dependencies are not met.
> Because the newest libc6-dev depends particularly on linux-kernel 
> (>= 4.9.18-1), and this is an error, at least I hope its not intentional.

Not it doesn't depends on the latest kernel. It depends on the latest
kernel *headers* which are provided by linux-libc-dev.

> Because many embedded armhf devices use older kernels, 4.1 , 4.4 ... so on
> , it depends on BSP what you can get from the HW vendor. Usually they have no 4.9 or any near to mainline kernel.

Yes, that's something known. libc6 requires at least a 3.2 kernel on
most architectures, and 2.6.32 on i386 and amd64.

> So they have no linux-libc-dev (>= 4.9.18-1)

You can install linux-libc-dev (>= 4.9.18-1) even if you're embedded
device uses a 4.1 or 4.4 kernel. It's provided in the Debian archive.

> So they cant install libc6-dev (2.24-10)
> So actually they can't develop.

Please try to install libc6-dev and linux-libc-dev from stretch or sid.
If it fails to install, please provide the error message from apt,
aptitude or dpkg showing the issue.

Aurelien Jarno                          GPG: 4096R/1DDD8C9B
aurelien@aurel32.net                 http://www.aurel32.net

Reply to: