[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#861518: libc6-dev: The newest libc6-dev (2.24-10) badly depends on kernel, particularly linux-libc-dev (>= 4.9.18-1)

Package: libc6-dev
Version: 2.24-10
Severity: important

Dear Maintainer,

   * What led up to the situation?
I tried to install libc6-dev on my armhf embedded hardware.
Its not possible, because dependencies are not met.
Because the newest libc6-dev depends particularly on linux-kernel 
(>= 4.9.18-1), and this is an error, at least I hope its not intentional.
Because many embedded armhf devices use older kernels, 4.1 , 4.4 ... so on
, it depends on BSP what you can get from the HW vendor. Usually they have no 4.9 or any near to mainline kernel.
So they have no linux-libc-dev (>= 4.9.18-1)
So they cant install libc6-dev (2.24-10)
So actually they can't develop.

Earlier libc6-dev (<=2.24-9) depended only on linux-libc-dev (without version), so it was installable.

-- System Information:
Debian Release: 9.0
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64

Kernel: Linux 4.9.0-2-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages libc6-dev depends on:
ii  libc-dev-bin    2.24-10
ii  libc6           2.24-10
ii  linux-libc-dev  4.9.18-1

libc6-dev recommends no packages.

Versions of packages libc6-dev suggests:
pn  glibc-doc     <none>
ii  manpages-dev  4.10-2

-- no debconf information

Reply to: