[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

r6222 - in glibc-package/trunk/debian: . control.in patches rules.d sysdeps testsuite-checking



Author: aurel32
Date: 2014-08-14 10:57:35 +0000 (Thu, 14 Aug 2014)
New Revision: 6222

Removed:
   glibc-package/trunk/debian/libc6.1.symbols.ia64
   glibc-package/trunk/debian/patches/ia64/
   glibc-package/trunk/debian/patches/series.ia64
   glibc-package/trunk/debian/sysdeps/ia64.mk
   glibc-package/trunk/debian/testsuite-checking/expected-results-ia64-linux-gnu-libc
Modified:
   glibc-package/trunk/debian/changelog
   glibc-package/trunk/debian/control
   glibc-package/trunk/debian/control.in/libc
   glibc-package/trunk/debian/control.in/main
   glibc-package/trunk/debian/glibc-source.filelist
   glibc-package/trunk/debian/patches/series
   glibc-package/trunk/debian/rules.d/control.mk
Log:
Remove ia64 support.  Closes: #756095.

Modified: glibc-package/trunk/debian/changelog
===================================================================
--- glibc-package/trunk/debian/changelog	2014-08-14 10:50:14 UTC (rev 6221)
+++ glibc-package/trunk/debian/changelog	2014-08-14 10:57:35 UTC (rev 6222)
@@ -9,6 +9,7 @@
   * debian/patches/s390/cvs-s390-abi-reversal.diff: new patch backported from
     upstream to revert the S/390 jmp_buf/ucontext_t ABI change.
   * Update Turkish debconf translation, by Mert Dirik.  Closes: #757495.
+  * Remove ia64 support.  Closes: #756095.
 
  -- Adam Conrad <adconrad@0c3.net>  Sat, 12 Jul 2014 20:53:51 -0600
 

Modified: glibc-package/trunk/debian/control
===================================================================
--- glibc-package/trunk/debian/control	2014-08-14 10:50:14 UTC (rev 6221)
+++ glibc-package/trunk/debian/control	2014-08-14 10:57:35 UTC (rev 6222)
@@ -130,8 +130,8 @@
 Architecture: any
 Multi-Arch: foreign
 Depends: ${misc:Depends},
-	 libc6 (>= 2.3.6-2) [!any-i386 !alpha !armhf !ia64 !hurd-any !kfreebsd-any],
-         libc6.1 (>= 2.3.6-2) [alpha ia64],
+	 libc6 (>= 2.3.6-2) [!any-i386 !alpha !armhf !hurd-any !kfreebsd-any],
+         libc6.1 (>= 2.3.6-2) [alpha],
          libc0.3 (>= 2.3.6-2) [!linux-any !kfreebsd-any !hurd-i386],
          libc0.1 (>= 2.3.6-2) [!linux-any !hurd-any !kfreebsd-i386],
          libc6 (>= 2.13-5) [armhf i386],
@@ -182,7 +182,7 @@
 Replaces: hurd-dev (<< 20120408-3) [hurd-i386]
 Recommends: gcc | c-compiler
 Suggests: glibc-doc, manpages-dev
-Provides: libc-dev, libc6-dev [alpha ia64 hurd-i386 kfreebsd-i386 kfreebsd-amd64]
+Provides: libc-dev, libc6-dev [alpha hurd-i386 kfreebsd-i386 kfreebsd-amd64]
 Breaks: binutils (<< 2.20.1-1), binutils-gold (<< 2.20.1-11), cmake (<< 2.8.4+dfsg.1-5), gcc-4.4 (<< 4.4.6-4), gcc-4.5 (<< 4.5.3-2), gcc-4.6 (<< 4.6.0-12), make (<< 3.81-8.1), pkg-config (<< 0.26-1), libjna-java (<< 3.2.7-4), liblouis-dev (<< 2.3.0-2), liblouisxml-dev (<< 2.4.0-2), libhwloc-dev (<< 1.2-3), check (<< 0.9.10-6.1+b1) [s390x]
 Conflicts: libc6.1-dev, libc0.1-dev, libc0.3-dev,
 Description: GNU C Library: Development Libraries and Header Files
@@ -243,7 +243,7 @@
  installer.  Do not install it on a normal system.
 
 Package: libc6.1
-Architecture: alpha ia64
+Architecture: alpha
 Section: libs
 Priority: required
 Multi-Arch: same
@@ -272,7 +272,7 @@
  and the standard math library, as well as many others.
 
 Package: libc6.1-dev
-Architecture: alpha ia64
+Architecture: alpha
 Section: libdevel
 Priority: optional
 Multi-Arch: same
@@ -280,7 +280,7 @@
 Replaces: hurd-dev (<< 20120408-3) [hurd-i386]
 Recommends: gcc | c-compiler
 Suggests: glibc-doc, manpages-dev
-Provides: libc-dev, libc6-dev [alpha ia64 hurd-i386 kfreebsd-i386 kfreebsd-amd64]
+Provides: libc-dev, libc6-dev [alpha hurd-i386 kfreebsd-i386 kfreebsd-amd64]
 Breaks: binutils (<< 2.20.1-1), binutils-gold (<< 2.20.1-11), cmake (<< 2.8.4+dfsg.1-5), gcc-4.4 (<< 4.4.6-4), gcc-4.5 (<< 4.5.3-2), gcc-4.6 (<< 4.6.0-12), make (<< 3.81-8.1), pkg-config (<< 0.26-1), libjna-java (<< 3.2.7-4), liblouis-dev (<< 2.3.0-2), liblouisxml-dev (<< 2.4.0-2), libhwloc-dev (<< 1.2-3), check (<< 0.9.10-6.1+b1) [s390x]
 Conflicts: libc6-dev, libc0.1-dev, libc0.3-dev,
 Description: GNU C Library: Development Libraries and Header Files
@@ -288,7 +288,7 @@
  and link programs which use the standard C library.
 
 Package: libc6.1-dbg
-Architecture: alpha ia64
+Architecture: alpha
 Section: debug
 Priority: extra
 Multi-Arch: same
@@ -300,7 +300,7 @@
  library.
 
 Package: libc6.1-prof
-Architecture: alpha ia64
+Architecture: alpha
 Section: libdevel
 Priority: extra
 Multi-Arch: same
@@ -311,7 +311,7 @@
  with gprof.
 
 Package: libc6.1-pic
-Architecture: alpha ia64
+Architecture: alpha
 Section: libdevel
 Priority: optional
 Multi-Arch: same
@@ -327,7 +327,7 @@
 
 Package: libc6.1-udeb
 XC-Package-Type: udeb
-Architecture: alpha ia64
+Architecture: alpha
 Section: debian-installer
 Priority: extra
 Provides: libc6.1, libc-udeb, ${locale-compat:Depends}
@@ -378,7 +378,7 @@
 Replaces: hurd-dev (<< 20120408-3) [hurd-i386]
 Recommends: gcc | c-compiler
 Suggests: glibc-doc, manpages-dev
-Provides: libc-dev, libc6-dev [alpha ia64 hurd-i386 kfreebsd-i386 kfreebsd-amd64]
+Provides: libc-dev, libc6-dev [alpha hurd-i386 kfreebsd-i386 kfreebsd-amd64]
 Breaks: binutils (<< 2.20.1-1), binutils-gold (<< 2.20.1-11), cmake (<< 2.8.4+dfsg.1-5), gcc-4.4 (<< 4.4.6-4), gcc-4.5 (<< 4.5.3-2), gcc-4.6 (<< 4.6.0-12), make (<< 3.81-8.1), pkg-config (<< 0.26-1), libjna-java (<< 3.2.7-4), liblouis-dev (<< 2.3.0-2), liblouisxml-dev (<< 2.4.0-2), libhwloc-dev (<< 1.2-3), check (<< 0.9.10-6.1+b1) [s390x]
 Conflicts: libc6-dev, libc6.1-dev, libc0.1-dev,
 Description: GNU C Library: Development Libraries and Header Files
@@ -476,7 +476,7 @@
 Replaces: hurd-dev (<< 20120408-3) [hurd-i386]
 Recommends: gcc | c-compiler
 Suggests: glibc-doc, manpages-dev
-Provides: libc-dev, libc6-dev [alpha ia64 hurd-i386 kfreebsd-i386 kfreebsd-amd64]
+Provides: libc-dev, libc6-dev [alpha hurd-i386 kfreebsd-i386 kfreebsd-amd64]
 Breaks: binutils (<< 2.20.1-1), binutils-gold (<< 2.20.1-11), cmake (<< 2.8.4+dfsg.1-5), gcc-4.4 (<< 4.4.6-4), gcc-4.5 (<< 4.5.3-2), gcc-4.6 (<< 4.6.0-12), make (<< 3.81-8.1), pkg-config (<< 0.26-1), libjna-java (<< 3.2.7-4), liblouis-dev (<< 2.3.0-2), liblouisxml-dev (<< 2.4.0-2), libhwloc-dev (<< 1.2-3), check (<< 0.9.10-6.1+b1) [s390x]
 Conflicts: libc6-dev, libc6.1-dev, libc0.3-dev,
 Description: GNU C Library: Development Libraries and Header Files

Modified: glibc-package/trunk/debian/control.in/libc
===================================================================
--- glibc-package/trunk/debian/control.in/libc	2014-08-14 10:50:14 UTC (rev 6221)
+++ glibc-package/trunk/debian/control.in/libc	2014-08-14 10:57:35 UTC (rev 6222)
@@ -36,7 +36,7 @@
 Replaces: hurd-dev (<< 20120408-3) [hurd-i386]
 Recommends: gcc | c-compiler
 Suggests: glibc-doc, manpages-dev
-Provides: libc-dev, libc6-dev [alpha ia64 hurd-i386 kfreebsd-i386 kfreebsd-amd64]
+Provides: libc-dev, libc6-dev [alpha hurd-i386 kfreebsd-i386 kfreebsd-amd64]
 Breaks: binutils (<< 2.20.1-1), binutils-gold (<< 2.20.1-11), cmake (<< 2.8.4+dfsg.1-5), gcc-4.4 (<< 4.4.6-4), gcc-4.5 (<< 4.5.3-2), gcc-4.6 (<< 4.6.0-12), make (<< 3.81-8.1), pkg-config (<< 0.26-1), libjna-java (<< 3.2.7-4), liblouis-dev (<< 2.3.0-2), liblouisxml-dev (<< 2.4.0-2), libhwloc-dev (<< 1.2-3), check (<< 0.9.10-6.1+b1) [s390x]
 Conflicts: @libc-dev-conflict@
 Description: GNU C Library: Development Libraries and Header Files

Modified: glibc-package/trunk/debian/control.in/main
===================================================================
--- glibc-package/trunk/debian/control.in/main	2014-08-14 10:50:14 UTC (rev 6221)
+++ glibc-package/trunk/debian/control.in/main	2014-08-14 10:57:35 UTC (rev 6222)
@@ -130,8 +130,8 @@
 Architecture: any
 Multi-Arch: foreign
 Depends: ${misc:Depends},
-	 libc6 (>= 2.3.6-2) [!any-i386 !alpha !armhf !ia64 !hurd-any !kfreebsd-any],
-         libc6.1 (>= 2.3.6-2) [alpha ia64],
+	 libc6 (>= 2.3.6-2) [!any-i386 !alpha !armhf !hurd-any !kfreebsd-any],
+         libc6.1 (>= 2.3.6-2) [alpha],
          libc0.3 (>= 2.3.6-2) [!linux-any !kfreebsd-any !hurd-i386],
          libc0.1 (>= 2.3.6-2) [!linux-any !hurd-any !kfreebsd-i386],
          libc6 (>= 2.13-5) [armhf i386],

Modified: glibc-package/trunk/debian/glibc-source.filelist
===================================================================
--- glibc-package/trunk/debian/glibc-source.filelist	2014-08-14 10:50:14 UTC (rev 6221)
+++ glibc-package/trunk/debian/glibc-source.filelist	2014-08-14 10:57:35 UTC (rev 6222)
@@ -12,7 +12,6 @@
 debian/libc6-ppc64.symbols.powerpc
 debian/libc6-sparc64.symbols.sparc
 debian/libc6.1.symbols.alpha
-debian/libc6.1.symbols.ia64
 debian/libc6.symbols.amd64
 debian/libc6.symbols.arm
 debian/libc6.symbols.armel

Deleted: glibc-package/trunk/debian/libc6.1.symbols.ia64
===================================================================
--- glibc-package/trunk/debian/libc6.1.symbols.ia64	2014-08-14 10:50:14 UTC (rev 6221)
+++ glibc-package/trunk/debian/libc6.1.symbols.ia64	2014-08-14 10:57:35 UTC (rev 6222)
@@ -1,59 +0,0 @@
-ld-linux-ia64.so.2 #PACKAGE# #MINVER#
-#include "symbols.wildcards"
-### TLS support added/enabled in debian upload 2.3.5
- __tls_get_addr@GLIBC_2.3 2.3.5
-libc.so.6.1 #PACKAGE# #MINVER#
-#include "symbols.wildcards"
- accept4@GLIBC_2.10 2.13-25~
-libBrokenLocale.so.1 #PACKAGE# #MINVER#
-#include "symbols.wildcards"
-libSegFault.so #PACKAGE# #MINVER#
- __invoke_dynamic_linker__@Base 2.3.6
-libcidn.so.1 #PACKAGE# #MINVER#
-#include "symbols.wildcards"
-libcrypt.so.1 #PACKAGE# #MINVER#
-#include "symbols.wildcards"
-libdl.so.2 #PACKAGE# #MINVER#
-#include "symbols.wildcards"
-libm.so.6.1 #PACKAGE# #MINVER#
-#include "symbols.wildcards"
-libmemusage.so #PACKAGE# #MINVER#
- __invoke_dynamic_linker__@Base 2.3.6
- calloc@Base 2.3.6
- free@Base 2.3.6
- malloc@Base 2.3.6
- mmap64@Base 2.3.6
- mmap@Base 2.3.6
- mremap@Base 2.3.6
- munmap@Base 2.3.6
- realloc@Base 2.3.6
-libnsl.so.1 #PACKAGE# #MINVER#
-#include "symbols.wildcards"
-libnss_compat.so.2 #PACKAGE# #MINVER#
-#include "symbols.wildcards"
-libnss_dns.so.2 #PACKAGE# #MINVER#
-#include "symbols.wildcards"
-libnss_files.so.2 #PACKAGE# #MINVER#
-#include "symbols.wildcards"
-libnss_hesiod.so.2 #PACKAGE# #MINVER#
-#include "symbols.wildcards"
-libnss_nis.so.2 #PACKAGE# #MINVER#
-#include "symbols.wildcards"
-libnss_nisplus.so.2 #PACKAGE# #MINVER#
-#include "symbols.wildcards"
-libpcprofile.so #PACKAGE# #MINVER#
- __cyg_profile_func_enter@Base 2.3.6
- __cyg_profile_func_exit@Base 2.3.6
- __invoke_dynamic_linker__@Base 2.3.6
-libresolv.so.2 #PACKAGE# #MINVER#
-#include "symbols.wildcards"
-librt.so.1 #PACKAGE# #MINVER#
-#include "symbols.wildcards"
-libutil.so.1 #PACKAGE# #MINVER#
-#include "symbols.wildcards"
-libanl.so.1 #PACKAGE# #MINVER#
-#include "symbols.wildcards"
-libpthread.so.0 #PACKAGE# #MINVER#
-#include "symbols.wildcards"
-libthread_db.so.1 #PACKAGE# #MINVER#
-#include "symbols.wildcards"

Modified: glibc-package/trunk/debian/patches/series
===================================================================
--- glibc-package/trunk/debian/patches/series	2014-08-14 10:50:14 UTC (rev 6221)
+++ glibc-package/trunk/debian/patches/series	2014-08-14 10:57:35 UTC (rev 6222)
@@ -153,10 +153,6 @@
 i386/submitted-i686-timing.diff
 i386/unsubmitted-quiet-ldconfig.diff
 
-ia64/local-dlfptr.diff
-ia64/submitted-libm.diff
-ia64/submitted-remainder.diff
-
 kfreebsd/submitted-waitid.diff
 kfreebsd/submitted-auxv.diff
 kfreebsd/local-config_h_in.patch

Deleted: glibc-package/trunk/debian/patches/series.ia64
===================================================================
--- glibc-package/trunk/debian/patches/series.ia64	2014-08-14 10:50:14 UTC (rev 6221)
+++ glibc-package/trunk/debian/patches/series.ia64	2014-08-14 10:57:35 UTC (rev 6222)
@@ -1,2 +0,0 @@
-ia64/local-rtld-compile-options.diff
-

Modified: glibc-package/trunk/debian/rules.d/control.mk
===================================================================
--- glibc-package/trunk/debian/rules.d/control.mk	2014-08-14 10:50:14 UTC (rev 6221)
+++ glibc-package/trunk/debian/rules.d/control.mk	2014-08-14 10:57:35 UTC (rev 6222)
@@ -2,7 +2,7 @@
 libc0_1_archs := kfreebsd-amd64 kfreebsd-i386
 libc0_3_archs := hurd-i386
 libc6_archs   := amd64 arm arm64 armel armhf hppa i386 m68k mips mipsel mipsn32 mipsn32el mips64 mips64el powerpc powerpcspe ppc64 ppc64el sparc sparc64 s390x sh4 x32
-libc6_1_archs := alpha ia64
+libc6_1_archs := alpha
 
 control_deps := $(wildcard debian/control.in/*) $(addprefix debian/control.in/, $(libc_packages))
 

Deleted: glibc-package/trunk/debian/sysdeps/ia64.mk
===================================================================
--- glibc-package/trunk/debian/sysdeps/ia64.mk	2014-08-14 10:50:14 UTC (rev 6221)
+++ glibc-package/trunk/debian/sysdeps/ia64.mk	2014-08-14 10:57:35 UTC (rev 6222)
@@ -1,3 +0,0 @@
-libc_add-ons = ports nptl $(add-ons)
-
-libc = libc6.1

Deleted: glibc-package/trunk/debian/testsuite-checking/expected-results-ia64-linux-gnu-libc
===================================================================
--- glibc-package/trunk/debian/testsuite-checking/expected-results-ia64-linux-gnu-libc	2014-08-14 10:50:14 UTC (rev 6221)
+++ glibc-package/trunk/debian/testsuite-checking/expected-results-ia64-linux-gnu-libc	2014-08-14 10:57:35 UTC (rev 6222)
@@ -1,26 +0,0 @@
-#
-# Allowed failures for ia64-linux-gnu-libc and the returned make
-# failure number, indicating the signal the process died with.
-# Format: <Failed test>, Error <Make error code> [(ignored)]
-#
-annexc.out, Error 1 (ignored)
-check-localplt.out, Error 1
-run-conformtest.out, Error 1 (ignored)
-test-double.out, Error 1
-test-idouble.out, Error 1
-test-float.out, Error 1
-test-ifloat.out, Error 1
-tst-backtrace4.out, Error 1
-tst-cpuclock2.out, Error 1
-tst-cputimer1.out, Error 1
-tst-getcpu.out, Error 1
-tst-long-dbl-fphex.out, Error 1
-tst-longjmp_chk2.out, Error 1
-tst-makecontext3.out, Error 1
-tst-setjmp-fp.out, Error 1
-tst-waitid.out, Error 1
-tst-writev.out, Error 1
-
-# This failure due to a GCC bug, this should be fixed in gcc-4.7 4.7.3-10
-# and gcc-4.8 4.8.2-9
-check-execstack.out, Error 1


Reply to: