[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: hppa nptl switch

Carlos O'Donell wrote:
>> In practice it shouldn't be problem at all.
>> Debian should make sure that binary/library compiled
>> against NPTL-hppa-glibc will require NPTL-hppa-glibc
>> by proper Depends: line like "libc6 (>= 2.10)".
> Does every package have to do this? I'm not very familiar with all the
> packaging requirements.

It is something that should automatically get done correctly as long as 
the libc-dev package defines the minimum version that way.

The mechanism that determines this is in /var/lib/dpkg/info/libc6.shlibs. 
Currently this has lines like:
   libc 6 libc6 (>= 2.9)

It's virtually certain that the shlibs file will be updated to read
'(>= 2.10)' when the glibc maintainers switch to that version.


Reply to: