[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#441824: libc6-dbg: /usr/lib/debug/ld-2.3.6.so should be executable

Package: libc6-dbg
Version: 2.3.6.ds1-13etch2

The dynamic loader shipped in libc6-dbg doesn't have the executable bit set.
This means you can't specify it to ld as the dynamic loader, which in turn
means that you can't get source line information in gdb for crashes inside
the dynamic loader.

mnementh$ cat >/tmp/t.c
#include <stdio.h>
int main(void) { printf("Hello world\n"); return 0; }
mnementh$ gcc -g -Wall -O2 -o /tmp/t /tmp/t.c -Xlinker --dynamic-linker -Xlinker /usr/lib/debug/ld-linux.so.2
mnementh$ /tmp/t
-bash: /tmp/t: Permission denied
mnementh$ ls -l /tmp/t
-rwxrwxr-x 1 pm215 pm215 8777 2007-09-11 12:09 /tmp/t
mnementh$ su
mnementh# chmod 775 /usr/lib/debug/ld-2.3.6.so
mnementh# exit
mnementh$ /tmp/t
Hello world

It would be nice if you could make the dynamic loader executable so
this just worked.

-- PMM

Reply to: