[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#420949: marked as done (New upgrade of libc6 2.5.* renders shells unusable)



Your message dated Thu, 26 Apr 2007 23:14:17 +0200
with message-id <20070426211417.GO5017@.madism.org>
and subject line Bug#420949: New upgrade of libc6 2.5.* renders shells unusable
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: libc6
Version: 2.5-4
Severity: critical
Justification: breaks unrelated software

Once again, with feeling.
1. Attempt to fix up dependencies and upgrade using apt -4 install. As soon
as it attempted to actually install this library, if failed with sh looking
for one of those lib....so.# which are no longer in /usr/lib.
2. So installed libc6 only (ok, afterwards, locale and other things need be
upgraded as well, but...) using dpkg -i. This succedes. Now bash can no
longer process bashrc files and any attempt to run simple commands (except
for cd) looks for those numberd .so libraries. Same problem as in previous
bug report.

So I will once more downgrade to 2.3.*. Little harm done.

Time to get to the bottom of this, please.

-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (990, 'unstable'), (650, 'testing'), (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.20-davidb (SMP w/1 CPU core; PREEMPT)
Locale: LANG=en_US, LC_CTYPE=en_US (charmap=locale: Cannot set LC_ALL to default locale: No such file or directory
ISO-8859-1)
Shell: /bin/sh linked to /bin/bash

-- debconf information:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LANG = "en_US"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_ALL to default locale: No such file or directory


--- End Message ---
--- Begin Message ---
On Thu, Apr 26, 2007 at 10:34:14PM +0200, Aurelien Jarno wrote:
> David Baron a écrit :
> >>>> LD_ASSUME_KERNEL="2.6.1" /lib/ld-2.5.so /lib/libc.so.6
> > 
> >>> I have a LD_ASSUME_KERNEL=2.4.19 in /etc/profile which was put there for 
> >>> jackd. Maybe I should get rid of that! Tried that with the upgrade and 
> >>> actually got into a bash login from the console but kdm would not restart to 
> >>> test it there. Had to downgrade once again.
> > 
> >> I have performed the entire apt-get -f install which placed the libc6 2.5.4 
> >> stuff as well as qt4 library updates and a few x modules.
> > 
> >> can start a bash shell using konsole or from a non-x console. After I do a 
> >> ew things, I will try to logout and logon kdm.
> > Worked OK!
> >> I will then try to restart x.  
> >> Might need to reboot first. If X restarts and I can login there, we can close 
> >> the bug.
> > I stopped and restarted and it was OK.
> > The next time I reboot, if it comes up OK (or if recompiling the nvidia..ko is 
> > needed and works OK), then we can close it!
> > 
> 
> Any news about that? Could we close the bug?

  As nvidia.ko is a kernel module hence does not uses libc, yes it can.

-- 
·O·  Pierre Habouzit
··O                                                madcoder@debian.org
OOO                                                http://www.madism.org

Attachment: pgpaqfruk0aB3.pgp
Description: PGP signature


--- End Message ---

Reply to: