[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: glibc 2.3.6-5

On Mon, Apr 03, 2006 at 03:57:16PM +0200, Aurelien Jarno wrote:
> Hi all,
> We now have an RC bug on the glibc (#360574), it can't be built from 
> source anymore.
> I think we have to upload glibc 2.3.6-5 soon, however, it has to pass 
> thru the NEW area as there is one more binary for the timezone.
> I also have patches that require to go to the NEW area again. Those 
> patches split the libc6 and libc6-dev packages, adding libc-bin and 
> libc-dev-bin. This is required by the policy and also by multiarch. 
> Those patches are ready, except that the log files do not go in the 
> right packages. I hope to be able to do that soon, but I am currently 
> having a really really tight schedule.

I also wanted to make similar changes for another reason: currently
locale-gen is shipped in the locales package, it calls localedef
from libc6 and needs data files from locales.
It is IMO better to have localedef and locale-gen in the same package,
as in belocs-locales-bin.  This means that another package will surely
be needed.  

> If I am not able to fix that soon (let's say for Thursday), I suggest to 
> upload a glibc splitted, but with the log files in the wrong places. 
> What do you think?

Maybe a safer alternative is to upload 2.3.6-5 without splitting tzdata,
and wotk on remaining issues as soon as possible.


Reply to: