[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#328440: libc6/NIS broken with bash/ksh/tcsh/sash

I have been following this somewhat closely as it is affecting me as
well. One thing I have tried is logging in as a user, unlike Alexander.
I get the same error as he is getting:

User jka is a member of the netgroup leonard, which has an entry
in /etc/passwd.

Via su:

teuber:~# su - jka
-su: nss_nis/nis-netgrp.c:79: _nss_nis_setnetgrent: Assertion
`malloc_usable_size (netgrp->data) >= len + 1' failed.

Via ssh:

teuber:~# ssh jka@localhost
Linux teuber 2.6.8-2-686-smp #1 SMP Thu May 19 17:27:55 JST 2005 i686
Last login: Thu Oct  6 16:08:40 2005 from localhost
-bash: nss_nis/nis-netgrp.c:79: _nss_nis_setnetgrent: Assertion
`malloc_usable_size (netgrp->data) >= len + 1' failed.
Connection to localhost closed.

In both cases, the shell for user jka is /bin/bash.

Debian package versions follow:

libc6          2.3.5-6
nis            3.14-2 
bash           3.0-15

Reply to: