Bug#325757: sparc32: catch-22 between kernel-image-2.4 and libc6_2.3.2.ds1-22
Peter Hanappe wrote:
> Package: libc6
> Version: 2.3.2.ds1-22
> Severity: grave
> On sparc32/sun4m:
> I'm upgrading from kernel 2.2.20 to 2.4.27 using the command:
> # apt-get install -f kernel-image-2.4.27-2-sparc32
> The kernel package depends on libc6_2.3.2.ds1-22_sparc.
> The installation of libc6 fails with the message:
> WARNING: You have a cpu which requires kernel 2.4.21
> or greater in order to install this version of glibc.
> Please upgrade the kernel before installing this package.
> kernel 2.4.27 requires libc6_2.3.2 but libc6_2.3.2 requires kernel
> 2.4.21 or greater. Any solutions?
Read the release notes (http://www.debian.org/releases/sarge/releasenotes)
and follow the upgrade instructions.