[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#325533: marked as done (libc6: can't upgrade)



Your message dated Mon, 29 Aug 2005 23:13:48 +0900
with message-id <81slwsvnj7.wl%gotom@debian.or.jp>
and subject line Bug#325533: libc6: can't upgrade
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--------------------------------------
Received: (at submit) by bugs.debian.org; 29 Aug 2005 09:08:15 +0000
>From lidaobing@gmail.com Mon Aug 29 02:08:15 2005
Return-path: <lidaobing@gmail.com>
Received: from zproxy.gmail.com [64.233.162.198] 
	by spohr.debian.org with esmtp (Exim 3.36 1 (Debian))
	id 1E9fcl-0002Bj-00; Mon, 29 Aug 2005 02:08:15 -0700
Received: by zproxy.gmail.com with SMTP id x3so552745nzd
        for <submit@bugs.debian.org>; Mon, 29 Aug 2005 02:07:44 -0700 (PDT)
DomainKey-Signature: a=rsa-sha1; q=dns; c=nofws;
        s=beta; d=gmail.com;
        h=received:message-id:date:from:to:subject:mime-version:content-type:content-transfer-encoding:content-disposition;
        b=FBMjao1QQ6yPhzblsHRVAnzrLbOuFwueBV6K4szAOnEw4DrnS7l2fnkBuzd9iD/3Q1GtZmQgpsX3aWjIXiL/35D3t3DNzIl1pMptnzAgLKkZf34jm+6rYsHuk9o3S9DeqK3yKb0A06ECqUH3QfgYJLAXA/E+lQxkLNQmKzIWFY4=
Received: by 10.37.15.28 with SMTP id s28mr632617nzi;
        Mon, 29 Aug 2005 02:07:44 -0700 (PDT)
Received: by 10.36.177.9 with HTTP; Mon, 29 Aug 2005 02:07:42 -0700 (PDT)
Message-ID: <8eae5a6605082902071f189a9b@mail.gmail.com>
Date: Mon, 29 Aug 2005 17:07:42 +0800
From: LI Daobing <lidaobing@gmail.com>
To: submit@bugs.debian.org
Subject: libc6: can't upgrade
Mime-Version: 1.0
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Level: 
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02

Package: libc6
Version: 2.3.2.ds1-18
Severity: important

can't upgrade libc6, it sounds conflict with base-files.
my base-files version is: 3.1.0.0.1.pure64

$ sudo aptitude install libc6
Reading Package Lists... Done
Building Dependency Tree
Reading extended state information
Initializing package states... Done
Reading task descriptions... Done
The following packages have been kept back:
  [snip]
The following packages will be upgraded:
  libc6
1 packages upgraded, 0 newly installed, 0 to remove and 424 not upgraded.
Need to get 0B/4318kB of archives. After unpacking 4096B will be freed.
Do you want to continue? [Y/n/?]
Writing extended state information... Done
(Reading database ... 43197 files and directories currently installed.)
Preparing to replace libc6 2.3.2.ds1-18 (using
.../libc6_2.3.2.ds1-22_amd64.deb) ...
Unpacking replacement libc6 ...
dpkg: error processing
/var/cache/apt/archives/libc6_2.3.2.ds1-22_amd64.deb (--unpack):
 trying to overwrite `/usr/lib64', which is also in package base-files
Errors were encountered while processing:
 /var/cache/apt/archives/libc6_2.3.2.ds1-22_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Ack!  Something bad happened while installing packages.  Trying to recover:
dpkg: dependency problems prevent configuration of libc6-dev:
 libc6-dev depends on libc6 (=3D 2.3.2.ds1-22); however:
  Version of libc6 on system is 2.3.2.ds1-18.
dpkg: error processing libc6-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of locales:
 locales depends on glibc-2.3.2.ds1-22; however:
  Package glibc-2.3.2.ds1-22 is not installed.
dpkg: error processing locales (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libc6-dev
 locales
Reading Package Lists... Done
Building Dependency Tree
Reading extended state information
Initializing package states... Done
Reading task descriptions... Done

-- System Information:
Debian Release: 3.1
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)
Kernel: Linux 2.6.11-9-amd64-k8
Locale: LANG=3DC, LC_CTYPE=3DC (charmap=3DANSI_X3.4-1968)

Versions of packages libc6 depends on:
ii  libdb1-compat                 2.1.3-7    The Berkeley database routines=
 [gl

-- no debconf information
--=20
LI Daobing

---------------------------------------
Received: (at 325533-done) by bugs.debian.org; 29 Aug 2005 14:13:49 +0000
>From gotom@debian.or.jp Mon Aug 29 07:13:49 2005
Return-path: <gotom@debian.or.jp>
Received: from omega.webmasters.gr.jp (webmasters.gr.jp) [218.44.239.78] 
	by spohr.debian.org with esmtp (Exim 3.36 1 (Debian))
	id 1E9kOT-00051G-00; Mon, 29 Aug 2005 07:13:49 -0700
Received: from omega.webmasters.gr.jp (localhost [127.0.0.1])
	by webmasters.gr.jp (Postfix) with ESMTP id 67B5DDEB9A;
	Mon, 29 Aug 2005 23:13:48 +0900 (JST)
Date: Mon, 29 Aug 2005 23:13:48 +0900
Message-ID: <81slwsvnj7.wl%gotom@debian.or.jp>
From: GOTO Masanori <gotom@debian.or.jp>
To: LI Daobing <lidaobing@gmail.com>, 325533-done@bugs.debian.org
Subject: Re: Bug#325533: libc6: can't upgrade
In-Reply-To: <8eae5a6605082902071f189a9b@mail.gmail.com>
References: <8eae5a6605082902071f189a9b@mail.gmail.com>
User-Agent: Wanderlust/2.11.30 (Wonderwall) SEMI/1.14.6 (Maruoka) FLIM/1.14.6 (Marutamachi) APEL/10.6 Emacs/21.4 (i386-pc-linux-gnu) MULE/5.0 (SAKAKI)
MIME-Version: 1.0 (generated by SEMI 1.14.6 - "Maruoka")
Content-Type: text/plain; charset=US-ASCII
Delivered-To: 325533-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Level: 
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02

At Mon, 29 Aug 2005 17:07:42 +0800,
LI Daobing wrote:
> can't upgrade libc6, it sounds conflict with base-files.
> my base-files version is: 3.1.0.0.1.pure64

And this error was introduced by amd64 porting teams.  We can't do
anything.  Please search debian-amd64 lists archive to know about
more.  IIRC, installing package by dpkg forcely should fix it.

Regards,
-- gotom



Reply to: