[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#324795: libc6 in stable broken on arm4vl

severity 324795 normal
tags 324795 moreinfo

At Wed, 24 Aug 2005 09:11:30 -0400,
Rob Warren wrote:
> I was upgrading from woody to sarge when apt-get choked on upgrading 
> libc6 from 2.2.5-11.8 to 2.3.2.ds1-22 with a message along the lines of 
> 'can't seek in file xxxxxx'. dmesg would report 'Bad number of 
> arguments for llseek()' (paraphrasing) every so often. It was 
> impossible to reserve the package install.

Weird.  Grep told me that dmesg (kernel 2.2.19) and glibc should not
warn such kind of messages.

> >> Linux jill 2.2.19 #1 Tue Dec 25 13:58:22 GMT 2001 armv4l unknown
> >
> > This kernel is not the standard debian supported kernel - it seems a
> > bit old.  Can you try newer kernel with glibc 2.3.2.ds1-22?
> 2.2.19 is the last kernel that I've run without problems; the machine 
> had an uptime of 221 days when I tried to upgrade.

Uptime is not important information for this kind of userland issue.

> Getting someone to access the machine is non-trivial and is going to 
> require shipping the computer.
> I won't be able to try anything for a few weeks until I get access to 
> the machine.

If so, we can't track down any more too - please send us the detailed 
information if you have an access for that machine.

-- gotom

Reply to: