[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: future libc6-sparcv9 and libc6-sparcv9b support

v9 is probably the most used optimized package. We cannot drop it. v9b is
used less, but it is still very important.

On Thu, Aug 18, 2005 at 02:07:28PM +0900, GOTO Masanori wrote:
> Hi,
> I have a question about optimization package: libc6-sparcv9 and
> libc6-sparcv9b.  Both packages are prepared for optimized versions of
> libc6.  They are currently supported - but I would like to know what
> the advantage of those packages is.  Just optimization?  Are those
> packages widely used?
> These days 2.6 kernel is getting popularity, so it's nice time to
> support NPTL on sparc systems.  But having a lot of optimized packages
> and variants like NPTL take much longer build time + maintenance cost.
> If we replace unpopular optimized libc6 packages with NPTL libc6 in
> future, it's much valuable for users, I think.
> How about to drop libc6-sparcv9/sparcv9b and introduce NPTL-enabled
> libc6 in future?
> Regards,
> -- gotom

Ubuntu     - http://www.ubuntu.com/
Debian     - http://www.debian.org/
Linux 1394 - http://www.linux1394.org/
SwissDisk  - http://www.swissdisk.com/

Reply to: