[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#318244: segmentation fault with many files

At Fri, 29 Jul 2005 19:51:34 +0300 (EEST),
Tuukka Toivonen wrote:
> > ulimit -a
> core file size        (blocks, -c) 0
> data seg size         (kbytes, -d) unlimited
> file size             (blocks, -f) unlimited
> max locked memory     (kbytes, -l) unlimited
> max memory size       (kbytes, -m) unlimited
> open files                    (-n) 1024
> pipe size          (512 bytes, -p) 8
> stack size            (kbytes, -s) 8192
> cpu time             (seconds, -t) unlimited
> max user processes            (-u) unlimited
> virtual memory        (kbytes, -v) unlimited
> >Tuukka, is it easy to reappear this problem again?
> Yes, it is easy to reproduce with the following script: create a new empty 
> directory and run the script in it:

I tried and it worked even the number was twice:

	gotom@moog:/tmp/318244$ cat Makefile
	config.h: $(wildcard */xxxx)
	        echo hmm

	gotom@moog:/tmp/318244$ LANG=C make clean
	make: *** No rule to make target `clean'.  Stop.
	gotom@moog:/tmp/318244$ ls | wc
	 280002  280002 2577799
	gotom@moog:/tmp/318244$ stat -f .
	  File: "."
	    ID: 0        Namelen: 255     Type: ext2/ext3
	Blocks: Total: 2519839    Free: 618524     Available: 592924     Size: 4096
	Inodes: Total: 1281696    Free: 612886    
	gotom@moog:/tmp/318244$ uname -r

The difference is kernel version and filesystem.  Could you track down
this problem more?  I think strace/ltrace probably help you.

-- gotom

Reply to: