[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#273248: libc6-i686: crashed my box just after install

At Fri, 24 Sep 2004 22:20:19 +0200,
Krzysztof Burghardt wrote:
> Instalation of optimized library breaks the whole system.
> After reboot init crashed with "Segmentation fault" message.
> I boot my box from CD and move /lib/tls/i686 to /lib/tls/i686-disabled.
> After this my system works as before.
> I tried to run /bin/true with this library:
> kb@techie:~$ LD_LIBRARY_PATH=/lib/tls/i686-disabled/cmov /bin/true
> Segmentation fault
> I tried to copy /bin and /lib to /tmp/root:
> kb@techie:/tmp$ sudo chroot root /bin/true
> Segmentation fault
> (/bin/strace is staticaly linked)
> kb@techie:/tmp$ sudo chroot root /bin/strace /bin/true
> No "Segmentation fault" when traced !?

I suspect your machine specific problem.

(1) Which processor do you use?
(2) Please download libc6-i686 and install it again.  Is it broken?
(3) Try: LD_LIBRARY_PATH=/lib/tls/i686-disabled/cmov ldd /bin/ls 

-- gotom

Reply to: