[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#200887: libc6 udate and subsequent attempt to reinstall fails

Package: libc6
Version: 2.3.1-17
Severity: grave
Tags: sid
Justification: renders package unusable

update fails, attempt to override fails:

sabre:/home/fade# apt-get install libc6
Reading Package Lists... Done
Building Dependency Tree... Done
Suggested packages:
1 packages upgraded, 0 newly installed, 0 to remove and 9 not upgraded.
1 packages not fully installed or removed.
Need to get 0B/3907kB of archives.
After unpacking 16.4kB disk space will be freed.
(Reading database ... 174930 files and directories currently installed.)
Preparing to replace libc6 2.3.1-17 (using .../libc6_2.3.1-17.0.1_powerpc.deb) ...
Unpacking replacement libc6 ...
dpkg: error processing /var/cache/apt/archives/libc6_2.3.1-17.0.1_powerpc.deb (--unpack):
 dpkg: warning - old post-removal script killed by signal (Segmentation fault)

dpkg: error while cleaning up:
 subprocess pre-installation script killed by signal (Segmentation fault)
Errors were encountered while processing:
Updating Debian Packages of System Configurations.
No samba users to configure, skipping.
E: Sub-process /usr/bin/dpkg returned an error code (1)

the system appears to still function, so I have submitted this as a grave bug.
I am a bit loathe to reset it at this point, though.Let me know if I can give
you any more information.

-- System Information:
Debian Release: testing/unstable
Architecture: powerpc
Kernel: Linux sabre 2.4.21-ben1-fade-sabre #1 Mon Jun 30 12:16:28 CEST 2003 ppc

Versions of packages libc6 depends on:
ii  libdb1-compat                 2.1.3-7    The Berkeley database routines [gl

-- no debconf information

Reply to: