[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#174140: libc6 2.3.1-6 is badly broken!

Package: libc6 (unstable)
Version: 2.3.1-6
Severity: critical

Earlier today, had an "unstable" workstation I decided to do
an "apt-get update;apt-get upgrade" to get the latest &
greatest.  All is well for a few minutes, until such time as
the apt-get blows up during the software install. Something
about unable to stat directory /var/cache/apt/updates/, libc6
not configured properly. Uh oh, this doesn't sound good. 
(Sorry I didn't have the foresight to write down the exact
messages, but if you'll read on, hopefully I can document this
enough to be reproducable).

All of my open X apps are running fine, but things are weird
in the shell. dpkg dies with the same error (complains about
/var/cache/apt/updates) whenever I try to do anything with it.
I can't reference the current "." directory, top and ps both
run but they don't show any process information, etc. I figure
I'm hosed, but give a fresh reboot just in case. LILO starts
normally but all I get at the login prompt is "unable to
determine TTY". Interesting.

At this point, though, I was curious whether I had just
stumbled across some weird anomaly caused by a strange
combination of packages on my machine, or whether something
was seriously broked in unstable distro.  Since there was no
vital data on the machine, I reformatted and did a fresh
install of Debian 3.0r0 from CD, just the base system to get
to a shell prompt and essential packages.  I set my apt source
to "unstable" (server ftp://ftp.debian.org) and tried to
install just the same libc6 that had caused problems before:
"apt-get update;apt-get install libc6", which causes dpkg to
break exactly as described above, and leaves the system in
exactly the same unusable state.

Target machine is a Pentium-III 450, 256MB, which had been
running Debian unstable for at least 6 months with no
problems.  The problem occured with both kernel 2.4.17 (first
time) and 2.2.18 (or whatever kernel 3.0 stable installs by

Sorry some of this isn't better documented, but as I said, all
I had to do to reproduce it was install the unstable libc6
package on a fresh stable system.  I won't be around the
machine in question again until next week, but would be happy
to answer any questions that might be useful.


Reply to: