[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: glibc 2.3 migration plans

On Sat, Oct 05, 2002 at 01:31:13PM -0400, Jack Howarth wrote:
> Ben,
>    Well on ppc we will have one specific requirement. All builds will
> have to be done on binutils or greater. This is because
> in binutils a glitch in how *r_offset was set was corrected
> (now its always zero) that prevented prelink from unprelinking back to
> the original binaries. This was because the value of *r_offset was set
> in an unpredictable manner before. The need for binutils
> is because of a bug that caused libraries to be created by ld which
> were not properly -zcombreloc and caused prelink to complain. This
> fix is multi-arch so while we don't know for sure if it effected non-ppc
> arches before, it certainly can't now.

Let me be clear: that is a requirement for _prelink_, not for glibc. 
Glibc should be fine with our current binutils packages.  So this does
not need to be done right away.

Daniel Jacobowitz
MontaVista Software                         Debian GNU/Linux Developer

Reply to: