[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#155917: ifenslave_0.07+2.5.15-1(m68k/unstable/q650): FTBFS on m68k



On Thu, Aug 08, 2002 at 07:12:05AM -0500, Stephen R Marenka wrote:

> Package: ifenslave
> Version: 0.07+2.5.15-1
> Severity: important
> Tags: sid
> 
> ifenslave fails to build from source.
> 
> Here are selected excerpts from the buildd log.
[...]
> | gcc -O2 -g -Wall -o ifenslave ifenslave.c
> | ifenslave.c: In function `main':
> | ifenslave.c:270: `SIOCBONDRELEASE' undeclared (first use in this function)
> | ifenslave.c:270: (Each undeclared identifier is reported only once
> | ifenslave.c:270: for each function it appears in.)
> | ifenslave.c:271: `BOND_RELEASE_OLD' undeclared (first use in this function)
> | ifenslave.c:440: `SIOCBONDENSLAVE' undeclared (first use in this function)
> | ifenslave.c:441: `BOND_ENSLAVE_OLD' undeclared (first use in this function)
> | ifenslave.c:446: `SIOCBONDCHANGEACTIVE' undeclared (first use in this function)
> | ifenslave.c:447: `BOND_CHANGE_ACTIVE_OLD' undeclared (first use in this function)
> | make: *** [build-stamp] Error 1
> 
> A full buildd log is available at 
> <http://buildd.debian.org/build.php?pkg=ifenslave&ver=0.07+2.5.15-1&arch=m68k>

I'm very curious why those definitions are present in
/usr/include/linux/sockios.h on every architecture except m68k.
If there's a good reason, I'll make sure ifenslave won't be built
anymore on m68k. If there isn't, I think this bug should be reassigned
to libc6-dev.

-- 
Met vriendelijke groet / with kind regards,
    Guus Sliepen <guus@sliepen.eu.org>

Attachment: pgp0WF5U_CupU.pgp
Description: PGP signature


Reply to: